[SOLVED] Still getting 'Session Expired...' Error

11 years 10 months ago #119853 by romannumeralus
I have paid for CB Subs and subscribed to your services. My client is getting upset. I keep running into the same issues. My site randomly generated the following error:

"Session expired or cookies are not enabled in your browser. Please press "reload page" in your browser, and enable cookies in your browser. Please refresh/reload page before filling-in."

The session is not expired. When you go the the login page and login, this is what you get (tried it in Chrome, FF, and IE). Reload does not change anything. Cookies are enabled. I even cleared the cache. Problem is, this is a sporadic error. It comes and goes pretty randomly. I need a fix for this immediately.

Please help! I am using the following setup:
Joomla 1.5.14 Stable
CB Subs 1.0.3
CB 1.2.1 (the latest version)

The problem started about a month ago and has been getting increasingly worse. I perused a few older threads and it was stated that this issue was fixed, but it isn't. PLEASE help ASAP.


EDIT: ADDED TAG SOLVED to subject.

Post edited by: beat, at: 2010/06/26 00:30

Please Log in to join the conversation.

11 years 10 months ago #119882 by krileon
Need more detailed information on your installation; see help us help you in my signature. Your Joomla version is out of date, please update it to 1.5.15.

Is it only doing this with CBSubs or just CB? Please clarify to determine if thread is in most appropriate boards. Have you tried a fresh install in a sub-domain or sub-folder to see if issue persists?

I experience this occasionally, but it's generally because i close my browser, which restores my previous location. In that time of my browser being closed my session expires. Upon restoring I sometimes receive said error depending on location of site it is attempting to restore to.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 10 months ago #119930 by romannumeralus
Replied by romannumeralus on topic Re:Still getting 'Session Expired...' Error!!!
I love your quick responses. Thank you.

Closing the browser is not the issue. This happens to everyone at very sporadic times. I have people testing the site all over the place with different types of browsers, all the same affect. When you try to login or register, you will randomly get that error no matter if you refresh, clear cache, go to a different browser, go to a different computer, enable cookies, or disable cookies. It's all the same. And then, seemingly randomly, you'll be able to login in again after several hours or even a day.

Here are more specific settings:

1. Exact PHP version. 5.2.8
2. Exact CB version. 1.2.1 (the latest version)
3. Exact Joomla version. 1.5.14 (will update, but doubt it's the cause)
4. Detailed description of problem. (screenshots? link?) Upon clicking attempting to login or register, you will receive this error: "Session expired or cookies are not enabled in your browser. Please press "reload page" in your browser, and enable cookies in your browser. Please refresh/reload page before filling-in." Of course, refreshing and reloading do not change anything. You just have to wait several hours and try again. This error is replicated across several Browsers and computers.
5. Any error messages reported with Joomla debug mode on and error reporting set to maximum? Have not turned on debug mode.
6. Any error messages reported with your hosts error log? Using GoDaddy Grid Server. No errors to report.
7. Any ACL modification components? (JACL, etc..) No ACL modifications. I am, however, using CB Subs 1.0.3.
8. Any SEF components? Joomla! SEO Settings are all set to 'Yes'. htaccess file has been properly renamed.
9. Move or encrypt configuration.php? Config file has been configured and uploaded conventionally.
10. Upgrade from CB version ?? or fresh install? Using the latest version of CB. Got same error from a previous installation on another server as well.
11. Migrated from Joomla version ?? or fresh install? Have not upgraded to 1.5.15 yet, but when current version was latest, error still presented itself.

I am getting this error even upon logging out and then trying to log back in, sometimes with a different user ID. This error has been replicated in a root installation on another server as well as in a subdirectory and seems to be completely random. There is not a specific scenario that I can come up with that triggers it. It just happens and no one can get onto the site.

The site in question can be found at http://client.goodseedsgooddeeds.com and once the site is stable, it will be moved to the root. As of right now, I am able to login just fine. However, last night and most of yesterday, I received the session expiration error I mentioned before. Likewise, the day before that, my client in Chicago was able to get on (as was I), whereas the 2 previous days, we could not get past that error. He uses IE, I use FF and Safari.

Please help! Let me know if you need any more information or if you need login credentials or anything else. I will backup and update to the most recent Joomla! installation, but I am fairly certain that is not the culprit.

Please Log in to join the conversation.

11 years 10 months ago #119976 by krileon
There's a few possible causes. The cookie checking is sensitive to ensure no one is obtaining access that shouldn't have access. Have you reviewed the fixes in this thread?

Solution 1
URL Rewrite from NON-www to www
[code:1]
RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
[/code:1]

Solution 2
Disable System Cache Joomla plugin.

Solution 3
PHP version could be the culprit if possible I recommend upgrading to PHP 5.2.10 or PHP 5.2.11.

Can't think of a direct cause of this. According to my search results it's not directly CB, but also Joomla experiencing the issue (same issue, but different error message).

Thread moved to CB boards.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 10 months ago #120004 by romannumeralus
Replied by romannumeralus on topic Re:Still getting 'Session Expired...' Error!!!
Thank you for the in depth response. Only time will tell if any of these will work. Again, the error is sporadic. Do you have any idea why this happens?

Please Log in to join the conversation.

11 years 10 months ago #120006 by krileon
romannumeralus wrote:

Thank you for the in depth response. Only time will tell if any of these will work. Again, the error is sporadic. Do you have any idea why this happens?


Not a clue. I only get it when I close my browser and my session expires. Then I open my browser which restores my tabs (Google Chrome) and trys to restore where I last was from cached data, which should result in the error (in my case it's working properly and as expected).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.225 seconds

Facebook Twitter LinkedIn