[#1291] Required fields still required when hidden

11 years 2 months ago #112534 by krileon
Greatly appreciate the testing, we will add a ticket for this to be investigated.

#1291

Post edited by: krileon, at: 2009/09/28 21:50


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 1 month ago #114704 by sumawelt
This also seems to happen when a field is required, hidden and the type is "textarea". I have a signup form with two textareas which are not needed for newslettersubscription. When i try to sign up for a newsletter it does hide these fields (because I set them to "show on profiles on 1 line") but even though hidden they are still required.
Is there a workaround, since I need those two fields to be textareas(and the type cannot be changed once the field is created)
Any help is appreciated :-)

Please Log in to join the conversation.

11 years 1 month ago #114723 by krileon
sumawelt wrote:

This also seems to happen when a field is required, hidden and the type is "textarea". I have a signup form with two textareas which are not needed for newslettersubscription. When i try to sign up for a newsletter it does hide these fields (because I set them to "show on profiles on 1 line") but even though hidden they are still required.
Is there a workaround, since I need those two fields to be textareas(and the type cannot be changed once the field is created)
Any help is appreciated :-)


This should be resolved in CBSubs 1.0.3. Please ensure you're using CBSubs 1.0.3.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 1 month ago #114734 by sumawelt
krileon wrote:

This should be resolved in CBSubs 1.0.3. Please ensure you're using CBSubs 1.0.3.


I am using 1.0.3
Can I PM you an url so you can verify? I don't want to post it public.
thanks

Please Log in to join the conversation.

11 years 1 month ago #114754 by krileon
sumawelt wrote:

krileon wrote:

This should be resolved in CBSubs 1.0.3. Please ensure you're using CBSubs 1.0.3.


I am using 1.0.3
Can I PM you an url so you can verify? I don't want to post it public.
thanks


Yes please do. I will examine your installation and see if there is an issue. It's possible there is a JS conflict. Am not able to duplicate on local and live test sites however.

Ensure your field is set to display on 1 line and not 2 lines, currently set to display on 2 lines it is bugged and will show the field anyway.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 1 month ago #114756 by krileon
sumawelt wrote:

This also seems to happen when a field is required, hidden and the type is "textarea". I have a signup form with two textareas which are not needed for newslettersubscription. When i try to sign up for a newsletter it does hide these fields (because I set them to "show on profiles on 1 line") but even though hidden they are still required.
Is there a workaround, since I need those two fields to be textareas(and the type cannot be changed once the field is created)
Any help is appreciated :-)


Was able to duplicate on live and local sites, will be adding to current ticket. Is confirmed bug.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.455 seconds

Facebook Twitter LinkedIn