[SOLVED] invalid argument from FB

9 years 3 months ago - 9 years 3 months ago #168041 by martsund_new
[SOLVED] invalid argument from FB was created by martsund_new
Hello,

After I changed the template I got this strange massage from FB:

Invalid argument. This link is not permitted by the application's configuration. Style 13

Can you help you please to solve this problem?

my site: www.guitarlir.dk


Best regards

Martin

Please Log in to join the conversation.

9 years 3 months ago #168079 by krileon
Replied by krileon on topic Re: invalid argument from FB
I don't see FBC anywhere on your site. The button is not present in the module. At any rate that error means the Site URL, as instructed to be configured by FBC, in your Facebook Application doesn't match the site you're at. In other words if you configured it for mysite.com and you're viewing www.mysite.com then it will error as they're not one in the same.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 3 months ago #168086 by martsund_new
Replied by martsund_new on topic Re: invalid argument from FB
Hey,

I had set the CB Plugins integration to 'No' in the module, because it does not work. But thank you for your reply, I will take a look at my configuration in the FB.

:) Martin

Please Log in to join the conversation.

9 years 3 months ago #168098 by martsund_new
Replied by martsund_new on topic Re: invalid argument from FB
Unfortunately It still give me trouble.. no matter what I do, it does'nt work.
in FB's Site URL I have tried to type:

guitarlir.dk
www.guitarlir.dk
www.guitarlir.dk
guitarlir.dk

But it will not work. Will you please help once again? :)

:) Martin

Please Log in to join the conversation.

9 years 3 months ago - 9 years 3 months ago #168103 by krileon
Replied by krileon on topic Re: invalid argument from FB
If you visit your site at:
http://guitarlir.dk/

Then you must specify that within Facebook. If you specify that in Facebook at you visit with:
http://www.guitarlir.dk/

Then it will NOT work. Please delete your Facebook Application and reconfigure. Configuring ONLY what is instructed by the documentation. Configuring ANYTHING else will likely result in it not working. The biggest problem is "Domain URL". If you have specified this it is guaranteed to fail.

Facebook is extremely picky with the URLs, it must be an exact match or they'll deny access to your Facebook Application.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 3 months ago #168109 by martsund_new
Replied by martsund_new on topic Re: invalid argument from FB
I did what you told me to do.

I deleted my apps in FB and created a new one.

I followed the description 100%... but I dont think it works ):

In the Site URL field I typed: guitarlir.dk/

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.454 seconds

Facebook Twitter LinkedIn