Can't choose other images when other then default template is chosen

2 months 1 week ago #306779 by jjsjjs
HI,

i copied and changed the default template, I modified the xml according to the new template name.
Installed it via plugin discovery, ok.
Now i can choose it as template in the Options, but then when going to the fields i can't choose the pending or empty image.
The same for canvas as for avatar.
When i choose the Default template in options, then i can choose another pending or empty image. But not the ones i prefer.

The structure of the custom template folder is exact the same as the default template folder.
The images and canvas fields can choose the images from /images/comprofiler/myfolder/canvas or avatar.

So when i can't choose the images for empty or pending from the custom template, then i can't choose a default canvas.

Any idea why this is?

Thanks for any help.
2 months 4 days ago #306814 by krileon
You need to change the profile template to your custom template within CB > Configuration > User Profile before those parameters will path to it. You don't need a custom template to add more images though. You can simply upload your new images to the below folders.

/components/com_comprofiler/plugin/templates/default/images/avatar
/components/com_comprofiler/plugin/templates/default/images/canvas


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 4 days ago #306821 by jjsjjs

krileon wrote: You need to change the profile template to your custom template within CB > Configuration > User Profile before those parameters will path to it. You don't need a custom template to add more images though. You can simply upload your new images to the below folders.

yes this is what i did

krileon wrote: /components/com_comprofiler/plugin/templates/default/images/avatar
/components/com_comprofiler/plugin/templates/default/images/canvas

yes i did that too, but when there is an update then the standard images will also be there again, and i don't want that.
So these folders i have now redirected to /images/comprofiler/myimages/avatar & canvas

But as i said, when i do what you also said, change the profile template within CB > Configuration > User Profile , then i can't choose my own images.
2 months 3 days ago #306838 by krileon

yes i did that too, but when there is an update then the standard images will also be there again, and i don't want that.

They don't hurt anything being there. Gallery images are not stored there so those images have no negative impact on any of the displays. Just be sure your images have their own unique names.

But as i said, when i do what you also said, change the profile template within CB > Configuration > User Profile , then i can't choose my own images.

There's a lot involved in creating a template and guessing a step was missed. CB Template Changer can generate installed templates using its Template Builder functionality to make things easier.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 3 days ago #306842 by jjsjjs
Ok thanks so far.
I will check the template i copied and changed the xml with, if i have something forgotten to alter.

Cheers.
Moderators: beatnantkrileon
Time to create page: 0.396 seconds
Facebook Twitter Google LinkedIn