Cant install or uninstall ANY version of community builder [ RESOLVED ]

1 year 3 months ago - 1 year 3 months ago #320618 by amvx86
Okay,

I've been at this for about 5 hours now. It's getting frustrating. No matter what version of php I've used 7.0, 7.2, 7.3 I CANNOT get community builder to install. At first it wouldn't upgrade and not it flat out wont install. I get the following errors:

Joomla\Filesystem\File::delete: Failed deleting inaccessible file CBApplication.php

I chmodded the files to www-data, directories 755 files 644.
I then chmodded to www-data with all files/directories to 777 NOTHING.

I downgraded to 2.4.2, 2.4.5, 2.4.4 wont install.

Joomla version is 3.9.21.

I have tried from the extensions directory and it didn't install, but on my on vps esxi instance of ubuntu running php 7.0 it ran and installed.

Please I am in desperate need of help here.

Thanks.


UPDATE -

Go into libraries within the site, locate the CBApp and it's directories. Reinstall. All works well.

Please Log in to join the conversation.

1 year 1 month ago #321505 by richbrundage
Alternate solution that works for me when I get the "Failed deleting inaccessible file xxx" error installing updates for CB or other extensions, which I found at help.joomlatools.com/article/338-known-issues

open the file located at libraries/vendor/joomla/filesystem/src/File.php and comment lines 124 to 127. You should end up having something like this:

/*if (!Path::canChmod($file))
{throw new FilesystemException(__METHOD__ . ': Failed deleting inaccessible file ' . $filename);
}*/
Removing those lines would also work.

Richard Brundage
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

1 year 1 month ago #321802 by TigrisMorte
Same issue.

Deleted CBLib from libraries,
back in joomla I tried the update.

worked with no error.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.174 seconds

Facebook Twitter LinkedIn