set field value with the value from another field

4 months 1 week ago #313121 by ericmuc
Hi, I read a lot, but my tests all dont't work at the moment.

What is the easyiest way to have autopopulate data from another field, trigger with user login, only if the field is not empty?

I tried Auto Action, field type, with trigger onUserLogin and this:

Next page I choose "Return"

That doesn't work, even the use of "2020-01-01" instead of [membersince] don't work. So what is wrong? Thanks for your help.
Attachments:
4 months 1 week ago #313122 by krileon
The field [membersince] does not exist. Are you trying to set it to their registration date? That'd be [registerdate], for last login date that'd be [lastvisitdate], and [lastupdatedate] for last profile update date.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 months 1 week ago #313141 by ericmuc

krileon wrote: The field [membersince] does not exist. Are you trying to set it to their registration date? That'd be [registerdate], for last login date that'd be [lastvisitdate], and [lastupdatedate] for last profile update date.


I am using now [registerdate] but I cannot get it working.



What now?
Attachments:
4 months 1 week ago #313148 by krileon
Do you have any conditions applied? If so please provide them. Beyond that I don't know what to suggest except provide the rest of your auto action configuration. The below appears to work in my tests.

Global
Triggers: onAfterLogin
Type: Field
Access: Everybody
Action
Field: cb_date (this is a Date field)
Operator: Set
Value: [registerdate]


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.442 seconds
Facebook Twitter Google LinkedIn