vulnerability

1 week 10 hours ago #315174 by Tuchisei
after the latest updates, my site has become unsafe, the vulnerability scan has listed the following Vulnerability:
/administrator/components/com_comprofiler/library/phpmailer/phpmailer.phpmailer.php
RCE: CVE-2016-10045, CVE-2016-10031
Attachments:
6 days 17 hours ago #315179 by krileon
There should be nothing in that file except a 3 line class pointer and some phpdoc. This has been the case since CB 2.0 released. Reinstall CB over it self to ensure it correctly updated. It is not possible for there to be a vulnerability in that file. We're currently using PHPMailer version 5.2.26. Looks like there's a 5.2.27 we can update to though just encase.

forge.joomlapolis.com/issues/7763


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: Tuchisei
Moderators: beatnantkrileon
Time to create page: 0.888 seconds