CB Activity comments in joomla articles

2 months 3 weeks ago #317136 by crealiagroup

krileon wrote: Does the article activity exist in CB Activity > Activity?

No activity exists.

krileon wrote: ensure CB Articles is published in CB > Plugin Management as it's used for handling the parsing of the display.

CB Articles is published
2 months 3 weeks ago #317140 by krileon
Strange, works fine in all my tests. Please PM backend super administrator login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 3 weeks ago #317170 by krileon
Activity for articles wasn't logging because the CB Auto Actions system plugin in Extensions > Plugins was not published and is necessary for CB Auto Actions to act on Joomla events.

As for comments CB Activity only outputs them if viewing an article directly. You'll notice the comments work fine when directly navigating to Joomlas content component using the below link.

index.php?option=com_content&view=article&id=145

To output comments on other views the "Include Context" parameter under "Comments and Likes" tab of the CB Activity Content Bot within Extensions > Plugins has to be adjusted to to allow for that. The context for direct article access (and default) is com_content.article. I've no idea what the context is for how you're outputting articles so I won't be able to help you there, but this seams to be due to how your Joomla template is overriding the article display.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 2 weeks ago - 2 months 2 weeks ago #317259 by crealiagroup
Issue in template layout solved, was missing <?php echo $this->item->event->afterDisplayContent; ?>

krileon wrote: I've no idea what the context is for how you're outputting articles so I won't be able to help you there

I want to show new articles and article comments inside index.php?option=com_comprofiler&view=pluginclass&plugin=cbactivity&action=activity for loggeding users.
2 months 2 weeks ago #317273 by krileon

I want to show new articles and article comments inside index.php?

Articles should be logging activity now when you create a new article. This won't apply to previous articles unless you re-save them to see if it'll generate their activity. These reason this wasn't working is the CB Auto Actions system plugin was not published and is what CB Auto Actions uses to act on Joomla events, which is what an article create will fire. Where they display is entirely up to you, but they should be displaying on the profile of the user who created the article and on Recent Activity as well as any stream that's outputting "article.%" asset.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 months 1 week ago #317374 by crealiagroup

krileon wrote: This won't apply to previous articles unless you re-save them to see if it'll generate their activity.


Ok, fine, it works. I can see new published articles.

Anyway now I see that the links of those articles to not route correctly to the article when SEF is activated. When SEF is on the link in the streaming is something like:

www.mysite.comm/component/content/article/my-article-name?Itemid=101

www.mysite.comm/category/my-article-name

Is that a bug or something misconfigured in CB/Joomla ?
Moderators: beatnantkrileon
Time to create page: 0.403 seconds

Facebook Twitter LinkedIn