duplicate header variables

5 years 11 months ago #201656 by wolverton
In the first post of this topic, you can see that CBJ is seeing values as headers beginning with header [31] , indicating that it's not seeing the EOL.
If EOL is set correctly, check the message to see if indeed there are duplicate headers causing the error message.
5 years 11 months ago #201672 by rustle44
Thank you Wolverton
I think you are correct with your diagnosis

this is the error message I am receiving:

CB Version =1.7
CBJ2_HEADER_VARIABLES are
Array ( [0] => cb_accpac [1] => name [2] => username [3] => email [4] => password [5] => block [6] => sendEmail [7] => registerDate [8] => lastvisitDate [9] => user_id [10] => params [11] => firstname [12] => middlename [13] => lastname [14] => hits [15] => activation [16] => message_last_sent [17] => message_number_sent [18] => avatar [19] => avatarapproved [20] => approved [21] => confirmed [22] => lastupdatedate [23] => registeripaddr [24] => cbactivation [25] => banned [26] => banneddate [27] => unbanneddate [28] => bannedby [29] => unbannedby [30] => bannedreason [31] => acceptedterms [32] => [33] => [34] => cb_companyaddress [35] => cb_citytown [36] => cb_provincestate [37] => cb_altcontactname [38] => cb_companyphone [39] => cb_contactcell [40] => cb_salesagentemail [41] => SALESPERSON [42] => cb_zippostalcode [43] => cb_country [44] => cb_teamleader [45] => cb_industry [46] => cb_secondaryphone [47] => cb_faxnumber [48] => cb_website [49] => cb_pb_enable [50] => cb_pb_autopublish [51] => cb_pb_notifyme [52] => cb_pb_enable_blog [53] => cb_pb_enable_wall [54] => cb_pb_autopublish_wall [55] => cb_pb_notifyme_wall [56] => cb_creditstanding [57] => usertype )

There are duplicate header variables which is not allowed.

Array ( [cb_accpac] => 1 [name] => 1 [username] => 1 => 1 [password] => 1 [block] => 1 [sendEmail] => 1 [registerDate] => 1 [lastvisitDate] => 1 [user_id] => 1 [params] => 1 [firstname] => 1 [middlename] => 1 [lastname] => 1 [hits] => 1 [activation] => 1 [message_last_sent] => 1 [message_number_sent] => 1 [avatar] => 1 [avatarapproved] => 1 [approved] => 1 [confirmed] => 1 [lastupdatedate] => 1 [registeripaddr] => 1 [cbactivation] => 1 [banned] => 1 [banneddate] => 1 [unbanneddate] => 1 [bannedby] => 1 [unbannedby] => 1 [bannedreason] => 1 [acceptedterms] => 1 [] => 2 [cb_companyaddress] => 1 [cb_citytown] => 1 [cb_provincestate] => 1 [cb_altcontactname] => 1 [cb_companyphone] => 1 [cb_contactcell] => 1 [cb_salesagentemail] => 1 [SALESPERSON] => 1 [cb_zippostalcode] => 1 [cb_country] => 1 [cb_teamleader] => 1 [cb_industry] => 1 [cb_secondaryphone] => 1 [cb_faxnumber] => 1 [cb_website] => 1 [cb_pb_enable] => 1 [cb_pb_autopublish] => 1 [cb_pb_notifyme] => 1 [cb_pb_enable_blog] => 1 [cb_pb_enable_wall] => 1 [cb_pb_autopublish_wall] => 1 [cb_pb_notifyme_wall] => 1 [cb_creditstanding] => 1 [usertype] => 1 ) there seems to be a slight difference between the fields headers, how would I go about correcting this with libre office (or another similar tool)? thank you in advance[email] => 1 [password] => 1 [block] => 1 [sendEmail] => 1 [registerDate] => 1 [lastvisitDate] => 1 [user_id] => 1 [params] => 1 [firstname] => 1 [middlename] => 1 [lastname] => 1 [hits] => 1 [activation] => 1 [message_last_sent] => 1 [message_number_sent] => 1 [avatar] => 1 [avatarapproved] => 1 [approved] => 1 [confirmed] => 1 [lastupdatedate] => 1 [registeripaddr] => 1 [cbactivation] => 1 [banned] => 1 [banneddate] => 1 [unbanneddate] => 1 [bannedby] => 1 [unbannedby] => 1 [bannedreason] => 1 [acceptedterms] => 1 [] => 2 [cb_companyaddress] => 1 [cb_citytown] => 1 [cb_provincestate] => 1 [cb_altcontactname] => 1 [cb_companyphone] => 1 [cb_contactcell] => 1 [cb_salesagentemail] => 1 [SALESPERSON] => 1 [cb_zippostalcode] => 1 [cb_country] => 1 [cb_teamleader] => 1 [cb_industry] => 1 [cb_secondaryphone] => 1 [cb_faxnumber] => 1 [cb_website] => 1 [cb_pb_enable] => 1 [cb_pb_autopublish] => 1 [cb_pb_notifyme] => 1 [cb_pb_enable_blog] => 1 [cb_pb_enable_wall] => 1 [cb_pb_autopublish_wall] => 1 [cb_pb_notifyme_wall] => 1 [cb_creditstanding] => 1 [usertype] => 1 )

there seems to be a slight difference between the fields headers, how would I go about correcting this with libre office (or another similar tool)?

thank you in advance
5 years 11 months ago #201673 by wolverton
Looks like you have two empty headers...

[32] => [33] =>
Moderators: beatnantjciconsultwolvertonkrileon
Time to create page: 0.163 seconds
Facebook Twitter Google LinkedIn