Tax not being applied

7 years 11 months ago #167626 by bubberz
I have upgraded to 1.2 successfully.

I have only one tax rate, and it's applied to all four of my plans.

when the user goes to pay, it's not on the invoice in the grand total or anywhere!

I thought I had all the CB and Sub settings correct, but something is missing.

Any suggestions would be HUGELY appreciated...I'm on almost day 3 of trying to get this figured out and have tried to go step by step through the documentation many times.

Thanks!
7 years 11 months ago #167637 by nant
7 years 11 months ago #167658 by bubberz
Hi!

No...no need to specify the country and company name, it's all in New Mexico (@ the moment) in the USA...and for personal use...no company name necessary.

www.fitfunfeminine.com/component/comprofiler/registers
7 years 10 months ago - 7 years 10 months ago #169281 by krileon
I could not confirm your issue. Within "Tax Rules" I've created "Sales Tax" and set it as the default. Once done in "Tax Rates" have created "Sales Tax" with a percentage charge (7% for my state) and applied to the "Sales Tax" rule. I've set it to apply to buyers and sellers everywhere as well as to apply it to all locations. This has proven to work flawlessly. However if you set the tax rate to be location based even moderately then the user MUST supply a country and state for the tax to calculate.

If issue persists please PM backend login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
7 years 10 months ago #169367 by bubberz
Hi...thanks for replying!

Within "Tax Rules", I have a rule called "LATaxRate"...and it's the default.
I have a tax rate of 7.32 and it's applied to "LaTaxRate".
Other settings are as follows:
Geographic Zone of Buyer - USA
Geographic Zone of Seller - USA
Applies inland - All
Applies to export - All
Applies in-state - All
Applies out-of-state - All
Published - Yes

Do I need to make the two zones more general >> i.e. to ALL or something? If so, how?

Thanks!
7 years 10 months ago #170196 by bubberz
Hi!

Any thoughts on what I need to do...or try?

Thanks!
Moderators: beatnantkrileon
Time to create page: 0.399 seconds