[PASSWORD] string not being replaced

5 months 14 hours ago #305374 by MarlonFungai
I am using a code Auto Action to send an SMS with the user password after registration. The site does not require email (I have code that replaces the email with [username]@domain.com thanks to another forum thread). Now the site sends the SMS without a problem but the [password] substitution doesn't work. I tried [username] and that works fine so I think from what you have said I am using the wrong trigger. I have used a few triggers and I have just tried onAfterUserRegistration with no luck. The other thing is CB is generating passwords they are not being entered at registration.
5 months 13 hours ago #305379 by krileon
You'd use onAfterUserRegistration for frontend registrations and onAfterNewUser for backend registrations. The [password] substitution should work fine for both but may not be the case if using generated passwords, but if not try directly accessing the user object with [var1_password].


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: MarlonFungai
5 months 12 hours ago #305385 by MarlonFungai
Accessing the password through [var1_password] worked a charm. Thank you.
The following user(s) said Thank You: krileon
Moderators: beatnantkrileon
Time to create page: 0.401 seconds
Facebook Twitter Google LinkedIn