[#7065] Username format -> This profile does not exist or is no longer available

4 months 1 week ago #302799 by heyai
Could it be that the username 24-bit mimics a joomla content id?

I can't update CB, as my clone site isn't running at the moment. That will take some time on my end, sorry.
Can you by any chance replicate this?

These are the components not prefixing user ID:
Community Builder userlist
Kunena forum link
Online users module
Newest users module

hey-ai - the community for asian guys and non-asian girls

The search bar is your friend, not just decoration!
4 months 1 week ago #302800 by krileon
Please PM a username where this isn't working and will try to reproduce or create a user on our demo site below with a username that isn't working to see if it works fine there.

demo.cbdemosites.com/


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 months 1 week ago #302811 by krileon
Ok, I see the issue. It's due to their username matching how URLs are formatted if the username isn't alias safe. So for example if their username is 20-tom it trys to go to the profile id of 20 instead of whatever that users after profile id is. Have added a bug ticket to look into this further as we'll probably need to specifically check for #- prefixed usernames to handle these cases.

forge.joomlapolis.com/issues/7065


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 months 1 week ago #302817 by krileon
Ok, was able to fix. If a username contains the reserved #- prefix then user id will be prefixed making for example 20-bob to 32-20-bob with 32 being their user id. This was already enforced for the alias (profile url) field, but wasn't being enforced in the router. Fixed build should be available sometime today or tomorrow.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 months 1 week ago #302822 by heyai
Awesome!

hey-ai - the community for asian guys and non-asian girls

The search bar is your friend, not just decoration!
Moderators: beatnantkrileon
Time to create page: 0.160 seconds
Facebook Twitter Google LinkedIn