[SOLVED] cb activity does not show the right time

6 months 2 weeks ago - 6 months 1 week ago #303598 by edmundcheong
Hi, i'm using cb activity version 4.2.1+build.2018.02.28.20.45.20.38cb85b8c and community builder version 2.1.4+build.2018.03.19.18.24.36.eaec2182a.

whenever we post anything on cb activity, the time captured is UTC, it wont offset the GMT in joomla setting. We have change various setting but it is still giving us timestamp GMT +0

is there any other setting that we should change?

is datetime capturing from mysql? as datenow showing the right time
6 months 1 week ago #303609 by krileon
The datetime is always stored in UTC then offset to server or local. For local offset it uses the users timezone specified within their Joomla user account (the params field for CB profile edit and registration). For server it uses whatever the global timezone setting is in Joomla. Edit your user within CB > User Management and check what your accounts timezone is. You can see the offset it's using when you hover the timeago usage long enough; it'll show as -OFFSET (e.g. -05:00) at the end of the datetime.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
6 months 1 week ago #303649 by edmundcheong

krileon wrote: The datetime is always stored in UTC then offset to server or local. For local offset it uses the users timezone specified within their Joomla user account (the params field for CB profile edit and registration). For server it uses whatever the global timezone setting is in Joomla.


Server time is correct.. which is my current time zone.. Joomla is currently UTC (default settings)

Edit your user within CB > User Management and check what your accounts timezone is. You can see the offset it's using when you hover the timeago usage long enough; it'll show as -OFFSET (e.g. -05:00) at the end of the datetime.


CB User management >> Allow CMS User Parameters is set to "No". Time ago is (11/04/2018 03:13:10) where else the right time is 11/04/2018 11:13:10
6 months 1 week ago #303656 by krileon
Even if you turn off user parameters you may still have a timezone saved to your user already. Edit your user within Joomla user manager and check what timezone is set for your account. Hover over the timeago longer as it'll show you the offset as part of the elements title. Not sure what more to suggest as this all works perfectly fine in my tests. Please ensure CB is completely up to date as there were some timeago issues awhile back that have long been fixed, but if you're not on latest build you may not have those fixes.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
6 months 1 week ago #303671 by edmundcheong
thanks, now the problem is solved
Moderators: beatnantkrileon
Time to create page: 0.393 seconds
Facebook Twitter Google LinkedIn