[SOLVED] Updating language files STILL does not update language files...

1 month 2 weeks ago #307580 by boyjahq
The following language plugins are installed:

Default language (English) 2.2.1+build.2018.09.11.16.46.02.170f744e4
en-GB English 2.2.1+build.2018.09.11.16.46.02.170f744e4
ja-JP Japanese 2.2.1+build.2018.09.11.16.46.02.170f744e4
CB Paid Subscriptions - en-GB 4.3.0+build.2018.09.19
CB Paid Subscriptions - ja-JP 4.3.0+build.2018.09.19

Despite the insistent indication that an update is required everything seems to be working, but I maintain these websites for non-technical clients and it is confusing for them to keep seeing this, which results in my having to respond to repeated requests to explain/fix it.

Where is Install from Web pulling version information to determine whether updates are required or not? Can I manually modify that file to make Install from Web think that the plugin is installed so that the Updates messages go away?
1 month 2 weeks ago #307582 by krileon
I've retested with the exact same language plugins you're using and still not having issues. I've no idea what's causing that version check to fail for you. I'm not sure what more to suggest as this is working fine in all my tests. I've spun up a clean install specifically to test this in addition to my normal test install and still works fine. I can't see any reason in the version check code for this either.

If you're not using any overrides in those language plugins try uninstalling them and re-installing them entirely. If you are using overrides be sure to backup your override.php file in the language plugins folder found below.

/components/com_comprofiler/plugin/language

If issue persists PM backend super administrator login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 2 weeks ago #307593 by boyjahq
Is there a proper way to uninstall the language plugins? When I select them in Community Builder: Plugin Management and click delete I am told that core plugins cannot be deleted.

Also, when I reinstall, do I even need the English plugin? Or does the Default language plugin handle that? And do I need CBSubs language plugins? Or is that now handled by the CB language plugins?
1 month 2 weeks ago #307605 by krileon

Is there a proper way to uninstall the language plugins? When I select them in Community Builder: Plugin Management and click delete I am told that core plugins cannot be deleted.

You can't delete the Default language plugin. You shouldn't have any issues deleting the others.

Also, when I reinstall, do I even need the English plugin?

No, you don't need the English language plugin unless you intend to use overrides that you only want loading for English.

Or does the Default language plugin handle that?

It does, yes.

And do I need CBSubs language plugins?

If you want to translate CBSubs, yes.

Or is that now handled by the CB language plugins?

No, not at this time.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 2 weeks ago #307621 by boyjahq
I figured out the problem.

The reason that the CB Language plugins en-GB and ja-JP were causing issues is because for some reason the iscore column in the comprofiler_plugin table was set to 1 for each of them. Which would explain why I was unable to delete them from the CB Plugin Management interface (kept getting error message that core plugins cannot be deleted) and it is why they were being marked with an incorrect version number, which I suppose is why the Install from Web mechanism kept telling me that they needed updating. So, I deleted the 2 rows for the CB language plugins from the comprofiler_plugin table, deleted the corresponding folders from the server, then reinstalled the CB language plugins. They are now showing the correct version number inside CB Plugin Management and Install from Web no longer insists that they need updating.

I can't imagine how the iscore column got set to 1 as I have never touched or looked at that table! Anyway, issue resolved. Hopefully this might help others on the forum who have been reporting similar problems.
The following user(s) said Thank You: nant, krileon
1 month 1 week ago #307635 by krileon
Strange, not sure how they were marked as a core plugin. If it's an older install that you've maintained it could've been something leftover from how language plugins were used to being handled. Good to know to look out for that, thank you!


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: nant
Moderators: beatnantkrileon
Time to create page: 0.381 seconds
Facebook Twitter Google LinkedIn