Search not working

1 month 4 hours ago #306146 by michaelgreen252
for some reason my searches will not return results if its in check box format...if its a radio button it works ok and also text fields...only check box will not return any results...any idea what may be wrong? thanks
4 weeks 2 days ago #306157 by krileon
Searches where? On a userlist or using Joomla search with CB Search Bot? In backend CB > User Management?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 weeks 2 days ago #306194 by michaelgreen252
Hey thanks..on the userllist.. if i search by text input or radio buttons then results are showing but if i tick a checkbox then there are no results.
4 weeks 2 days ago #306197 by michaelgreen252
update..with 2 findings in case it helps any...and im still referring to the userlist search criteria fields

1...when i switched the search criteria from (simple exact match ) which does not work.....to (simple any word match) i started getting results in the search.......but i should be finding results with exact match because these are checkboxes with pre selected search terms...

2..the search form does not reset...meaning after i search ...and find results...and then click on search users again...the same options that were ticked are still ticked....any idea how to get the search forms to clear after a search?
4 weeks 1 day ago #306200 by krileon

1...when i switched the search criteria from (simple exact match ) which does not work.....to (simple any word match) i started getting results in the search.......but i should be finding results with exact match because these are checkboxes with pre selected search terms...

Simple exact only finds results if what you selected exactly matches what another user has selected. So if you select 2 checkboxes then it only finds users who also selected exactly those 2 checkboxes and nothing more or less. Simply any can do partial matches and is likely what you're needing.

2..the search form does not reset...meaning after i search ...and find results...and then click on search users again...the same options that were ticked are still ticked....any idea how to get the search forms to clear after a search?

Click List All under the Search Users button to reset the search.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.379 seconds