[#7263] Updating the language plug ins of CB Subs

1 year 3 months ago - 1 year 3 months ago #307097 by lucablue
Hi,
this morning I've seen there were 2 update for CB Subs language plug in (Italian and English), so I went to admin to use the automatic update of CB Plug ins and it installed them succesfully.

The problem is that the system says the 2 plug ins are not yet updated... I've tried different times.
1 year 3 months ago - 1 year 3 months ago #307098 by krileon
CBSubs language plugins were redone in how they are built. Their XML file and plugin element is now properly unique. This means it can't replace your previous CBSubs language plugins and you'll have to delete the old ones manually after installing the new one. Note you will only have to do this once as once the new plugins are installed they'll update fine.

There's likely also a matching issue because of this change in the Install from Web version checker that will be looked into today.

forge.joomlapolis.com/issues/7263


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: nant, lucablue
1 year 3 months ago #307106 by krileon
Ok, version check for CBSubs language plugins should be fixed in latest CB build just released.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: nant
1 year 3 months ago #307146 by lucablue
I've disinstalled the old plug ins and installed new.

Everything seems ok but:

1) some phrases into subs are not translated, I've checked them into the override parameters of plug in but I cannot find them
2) I've read the cbsubscription_languageplugin directory and seems that in it_IT there are no language.php and admin_language.php, as in all other subdirectory, where the plug in install the italian languages? Where can I find just these two files to upload into my website?

Thank you
1 year 3 months ago #307148 by nant

lucablue wrote: I've disinstalled the old plug ins and installed new.

Everything seems ok but:

1) some phrases into subs are not translated, I've checked them into the override parameters of plug in but I cannot find them
2) I've read the cbsubscription_languageplugin directory and seems that in it_IT there are no language.php and admin_language.php, as in all other subdirectory, where the plug in install the italian languages? Where can I find just these two files to upload into my website?

Thank you


The cbsubs italian project on transifex can be found here:

www.transifex.com/joomlapolis/cbsubs/language/it_IT/

and it seems to be 100% translated.
1 year 3 months ago #307153 by lucablue
Hi Nant,
I'm sure of that but I say that inside the language subdirectory of my website are not present language.php nor admin_language.php as in all other languages subdirectory...

Anyway, I've changed the order of the plugins inside CB plug ins and now it seems to work good... but remain the mistery about the 2 files I've said about. They are not where they should.
Moderators: beatnantkrileon
Time to create page: 0.449 seconds
Facebook Twitter Google LinkedIn