[SOLVED] Problem: Row size too large

1 week 5 days ago #307225 by krileon
What MySQL version are you using? Sorry, I don't have much to suggest beyond what's already in the linked thread. I'm not database expert or server admin and you may want to consider contacting your host regarding your issue as it sounds like there's still a configuration problem (likely wrong file format). Recommend reading though the below for possible solutions.

dba.stackexchange.com/questions/6598/innodb-create-table-error-row-size-too-large

If configured correctly using the following then text columns should be small 20 byte pointers and easily be able to have hundreds of them without issue.

phpmyadmin settings:
Storage Engine: InnoDB
ROW_FORMAT: DYNAMIC

database settings:
innodb_large_prefix = 1
innodb_file_per_table = 1
innodb_file_format = Barracuda

Eventually we'll be completely redoing how fields are stored. Ideally we'll use a separate table that is just joined together with _comprofiler and in theory would allow for unlimited fields, but that won't be until at least CB 3.0.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 week 5 days ago #307231 by haasdijk
I'm using MariaDB 10.2.17, with settings as mentioned. I did ask my host to change the innodb_page_size to 64k. Maybe that helps.

Really looking forward to CB3.0 now :-)

Thanks,
Peter
1 week 5 days ago #307233 by krileon
MariaDB is not a supported database engine. So there's nothing more I can advise. It is not officially supported by Joomla and thus not supported by CB. We do not test on MariaDB either so you may or may not run into other issues.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 week 4 days ago #307239 by haasdijk
Nick,

this morning we replaced mariadb with mysql. I have been able to add a few fields. So it seems to work now with InnoDB_page_size still at 16.
Based on a tip from Tobius I have made the following changes in php.ini before (i didn't change them back):
max_input_nesting_level = 120
max_input_vars = 5000
memory_limit = 128M
Thanks for your patience.

Regards,
Peter
The following user(s) said Thank You: nant, krileon
Moderators: beatnantkrileon
Time to create page: 0.378 seconds
Facebook Twitter Google LinkedIn