[SOLVED] [#7279] Translation dificulties with CB Subs 4.3.0

1 month 3 weeks ago - 1 month 3 weeks ago #307451 by krileon
Ok, looks like the display directly on the basket is using the below strings.

[PREFIX_TEXT] [ITEM_NAME][VALIDITY_IF_NOT_AUTORECURRING] for [USERNAME]

or

[PREFIX_TEXT] [ITEM_NAME] for [USERNAME]

Have confirmed translating it works fine. Please give that one a try. If not check what you've "Payment item text" set to under the Pricing tab of your plan as that appears to be the string being used.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 3 weeks ago #307469 by erichburkhard
1)

Hi - so the string that definitely works is (just in case other people have the same issue):

'[ITEM_NAME] for [USERNAME]' => '[ITEM_NAME] para [USERNAME]'

from my point of view not so easy to find out, because in my CB Subs backenend: (Paid Subscription / Settings / Display / Baskets) the displayed key is [ITEMS_ALIASES] for [USERNAME]

...but anyway: THANKS for your help :-)

2)

Concerning the colour of the installed CB Subs language Plugins: I have checked on automatic version checking and deinstalled the old plugin (and then physically deleted the 'old' files & folders via ftp) and then re-installed the newest CB Subs language Plugin again -> it had no effect --> colour is still not green (but the plugin works fine)
1 month 3 weeks ago #307493 by krileon
Automatic version checking applies to CB it self only. You need to be sure specifically "Plugin Version Checking" is set to "Yes" within CB > Configuration > Integrations for plugin version checking. Plugin version checking is default enabled and has to be specifically disabled. Please also ensure you've the latest CB build installed as there was a recent bug with CBSubs language plugin version checking in CB it self.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 2 weeks ago #307596 by erichburkhard
so I loadad the latest version of CB and now the version checking of these language plugins works. THANKS
The following user(s) said Thank You: krileon
Moderators: beatnantkrileon
Time to create page: 0.419 seconds
Facebook Twitter Google LinkedIn