Urgent - New Member Emails Have Stopped Sending

1 month 1 week ago #307789 by bins
Kyle,

the good thing about Elastic Email, as opposed to SES, is that you can see the log of emails being sent and Acymail (via their API) & System + JEvent emails are also showing as passing through.
1 month 1 week ago #307791 by krileon
There won't be any logs for the emails failing to send from CB because the SMTP connection is failing. Have you tried adding the SMTP Port to the SMTP Host as shown below?

www.joomlapolis.com/forum/153-professional-member-support/238451-smtp-mail-not-working#301458


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
3 weeks 1 day ago #308107 by bins
Here are some updates:

It has taken over a week for elastic email to come back to me to say that they are looking at the issue. Apparently, they have an issue with their contact form - I hope it isn't an email delivery issue?

All emails, except CB are going through EE.

The Joomla SMTP setup for EE does not work. I am using their connector J! component.

CB emails have started to go again, but, I guess via php mail, but are being delayed, some by 36-48 hours. I need to see why this is happening.
3 weeks 19 hours ago #308114 by krileon

The Joomla SMTP setup for EE does not work. I am using their connector J! component.

This is likely your issue then. You're not sending emails properly through PHPMailer library that both Joomla and CB use. Their component is likely just acting on Joomla events and replacing the mailer functionality in Joomla and since it doesn't also do this for CB it won't work with CB. Elastic Email appears to have SMTP settings though. Have you tried the below?

elasticemail.com/resources/settings/smtp-api/


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 weeks 6 days ago #308137 by bins
I have, thanks.

I think EE have to resolve this or we move back to Amazon or another supplier.
2 weeks 1 day ago - 2 weeks 1 day ago #308275 by bins
Finally got some feedback:

'After longer investigation it turns out that the <Elastic Email> Joomla plugins are a bit outdated and will need some additional work at our Developer Team'.

Ok, it doesn't resolve the basic SMTP connectivity issues, but does identify part of the problem
The following user(s) said Thank You: krileon
Moderators: beatnantkrileon
Time to create page: 0.379 seconds
Facebook Twitter Google LinkedIn