CB Subs + Promotions

5 days 6 hours ago #309149 by l3g0s
Hi all,

I have a problem when I use a promotion that reduces the price to 0. When the user click on the "active" (opacity=1) submit button (after tick the checkbox rules), nothing is happening. Apparently, the button doesn't submit the form. I have no js error in the dev tools (F12). If I copy the url from the <form> action and paste it into my webbrowser, it works.
Have you got an idea ?

I have other problems with the promotions that I probably talked about in new posts to not mix everything.

Thank you so much for your work :)


Best regards,

Cyril.
2 days 19 hours ago #309160 by krileon
This strictly only happens when the price is zero? Have you tried any other promotions or without promotions and it works fine? Is this with a plan that's single payments only, recurring only, or allows both? Typically a single payment basket made free with a promotion should immediately activate when clicking the button, which should've changed to a "Confirm Order" button. Sounds like you're requiring users to accept the terms and conditions before paying though. Try turning that off within CBSubs > Settings > Display > Baskets and see if your issue persists.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
2 days 9 hours ago #309180 by l3g0s
Thank you for your answer.

The problem appends only when the price is zero. The button changes well when the price is zero. I disabled the acceptance of the terms and it did not change anything. It works fine without promotion. There is no recurring payment.
1 day 18 hours ago #309189 by krileon
Strange, working fine in my tests. Please PM backend super administrator login credentials as well as exact steps to reproduce the issue and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.399 seconds
Facebook Twitter Google LinkedIn