[SOLVED] Can't install or update CB packages

1 month 1 week ago - 1 month 3 days ago #326416 by MarlonFungai
[SOLVED] Can't install or update CB packages was created by MarlonFungai
Hi guys I have been getting errors when I try and update or install CB packages both manually and using install from web. I get the following error and aside from the core CB all other installs fail.

"System Information
Joomla: 3.10.2
Community Builder: 2.6.2
PHP: 7.4.23
Database: mysql 5.7.35

Package
File: 067_cbplug_lang_cbsubs_english_en-GB_4.5.2+build.2021.08.07.zip
Log:
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
"

Please Log in to join the conversation.

1 month 5 days ago #326426 by krileon
Replied by krileon on topic Can't install or update CB packages
If you're seeing that error then it typically means something has broken the JSON response for the package installer. Usually caused by some 3rd party extension echoing something even during &format=raw URLs. It's possible the plugin installed despite seeing that error. Navigate to CB > Plugin Management and see if that plugin updated fine despite the error.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 5 days ago #326434 by MarlonFungai
Replied by MarlonFungai on topic Can't install or update CB packages
It seems they aren't installing is there a way I can hunt down the offending extension and uninstall it?

Please Log in to join the conversation.

1 month 5 days ago - 1 month 5 days ago #326435 by krileon
Replied by krileon on topic Can't install or update CB packages
Press F12 to open your browsers developer console then attempt to install something and check the Network tab for the HTTP request to install something. From there you can review its response and see what is happening to the JSON data. An example of a working response is as follows.

URL: /index.php?option=com_comprofiler&view=editPlugin&action=installpkg&cid=56&fld=plugins&pkg=013_cbautoactionsbot_8.1.0%2Bbuild.2021.09.17.15.43.10.d1f5f09a0.zip&format=raw
Response:
{"status":"success","message":"This plugin allows CB Auto Actions to act on Joomla events by routing Joomla events to Community Builder events. All Joomla events are prefixed with joomla_ (e.g. joomla_onContentPrepare). Note all this plugin does is ensure CB Auto Actions has been loaded on every page to allow for event binding."}

Notice the response is valid JSON. If there's something before { or after } then something on your site is echoing data and breaking the response.

They should still be installing though since this is the final step of the process and is just the response message. Try downloading something that's failing manually from our downloads page below.

www.joomlapolis.com/downloads

Next unzip it and find whatever you're trying to install in /extensions folder and its various subfolders then try installing that manually to see if any errors output. Something is directly failing on your site is why the installer is failing. This usually means some sort of top level error is breaking things.

The usual culprit is a 3rd party system plugin loading on every page and causing issues.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 4 days ago #326440 by MarlonFungai
Replied by MarlonFungai on topic Can't install or update CB packages
Ok firstly I don't understand the results I am getting: 1. I checked the console output and it seems like after trying to install CB Subs something is creating a 403 error that then is included on every request and response. 2. I tried taking just one plugin CB AutoActions and unzipping it on my temp folder in the server directory but when I do that and specify the temp directory the package installer attempts to install all the packages I have in exactly the same manner it did in install from web. I cleared cache and tried again a few times same result. I then manually deleted everything in the temp directory and got the same result. I am not sure a why the installer is trying to update other packages and b what to try next.

Please Log in to join the conversation.

1 month 4 days ago #326442 by krileon
Replied by krileon on topic Can't install or update CB packages
Please PM backend super user login credentials (link in signature to directly PM me) and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.312 seconds

Facebook Twitter LinkedIn