CBSubs not working and getting errors

2 months 3 weeks ago - 2 months 3 weeks ago #329143 by wjgadmin
Replied by wjgadmin on topic CBSubs not working and getting errors
sorry here are the details with debugging...


Attachments:

Please Log in to join the conversation.

2 months 3 weeks ago #329145 by krileon
Replied by krileon on topic CBSubs not working and getting errors
That does appear to be a bug. Have added a bug ticket and am preparing a fix for a new CBSubs build release.

forge.joomlapolis.com/issues/8924


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 3 weeks ago #329146 by wjgadmin
Replied by wjgadmin on topic CBSubs not working and getting errors
ok thanks, i will get it updated as soon as available & do our best to handle every url http post that comes in manually for now.

Please Log in to join the conversation.

2 months 3 weeks ago #329150 by wjgadmin
Replied by wjgadmin on topic CBSubs not working and getting errors
i see that the ticket was completed. does that mean it would be available? apologies, not familiar with your update/ticket system.
if possible, and it is not available for an update, could you provide the single resolution so we could make it on our end to ensure our system is functioning? thank you

Please Log in to join the conversation.

2 months 3 weeks ago #329152 by krileon
Replied by krileon on topic CBSubs not working and getting errors
We have peer review here. So a fix has been completed and submitted for review by Beat. Once reviewed and the fix merged we'll release a new build. Should be available either sometime today or early tomorrow. Below is the fix that you can patch yourself if you need this now.

IN: /components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/plugin/cbsubsurl/cbsubs.url.php
ON: Line
FROM:
							$options['body']			=	$body;
TO:
							if ( cbGuzzleVersion() >= 6 ) {
								$options['form_params']	=	$body;
							} else {
								$options['body']		=	$body;
							}


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 3 weeks ago #329153 by wjgadmin
Replied by wjgadmin on topic CBSubs not working and getting errors
thank you, that did seem to resolve it on our end as well. i look forward to the release :)
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.246 seconds

Facebook Twitter LinkedIn