(solved) link to profiles in cb lose left modules

15 years 4 months ago #20598 by mattpist
im not sure if this is a bug or my own fault, but whenever i click on a link to another person's profile in cb, it takes me to the profile, but my left modules disappear.

this also happens with any other component/module links to a profile such as:

joomlaboard
who's online module (links usernames to profiles - 3rd party module)
and a few others ive tested but can't remember

i have the modules published for my menu links to the profiles (which work fine) but i can't seem to find the pages they're linking to within cb to make sure the modules are published there too. there just isn't an option.

it seems like im getting two different links/userids. when i view my profile from my main menu, the left modules show up fine. but when i click on the link in cb or joomlaboard, i get the profile without the left modules.

if i set the left login module to "all" instead of select pages, all the links work. unfortunately i can't set the modules to "all" due to template issues that can't be fixed.

anyways, id really appreciate the help.

EDIT: after further investigation, this seems to apply to ALL links in cb, such as links in the forum tab, blog tab, etc. the left modules are not appearing in any of these links.

Post edited by: mattpist, at: 2006/09/14 21:27

Please Log in to join the conversation.

15 years 4 months ago #20744 by mattpist
Replied by mattpist on topic Re:link to profiles in cb lose left modules
anyone? this seems like something that should be fixed...

Please Log in to join the conversation.

15 years 4 months ago #20871 by Thornbrand
Replied by Thornbrand on topic Re:link to profiles in cb lose left modules
I've been pulling my hair out for the last six hours or so with exactly the same problem, but I think I've found a working solution.

Like you, I required modules to show in one column (right side in my case) only for specific pages and items. This seemed to work fine until I followed a user link from the CB Online module and noticed that these modules didn't show for that or any profile.

The problem appears to stem from the fact that links from this module, and other links like you have identified, do not contain an Itemid=n.

My guess is that Joomla has no way of knowing if the requested page is related to a specific menu item or page. In this case Joomla should use the homepage module assignments, but obviously isn't.

The solution that worked for me was to assign my modules to the pages I desired, as well as the "unassigned" menu item link (instead of "all"). This tells Joomla that if no appropriate menu page relationship can be established, go ahead and publish those modules there.

So far this appears to be working brilliantly for me - hope it does for you as well.

Please Log in to join the conversation.

15 years 4 months ago #20900 by mattpist
Replied by mattpist on topic Re:link to profiles in cb lose left modules
oh hell yeah, that totally worked.... thank you SO much for that solution!!!

Please Log in to join the conversation.

14 years 11 months ago #31051 by bjraines
Replied by bjraines on topic Re:link to profiles in cb lose left modules
Thornbrand wrote:

I've been pulling my hair out for the last six hours or so with exactly the same problem, but I think I've found a working solution.

Like you, I required modules to show in one column (right side in my case) only for specific pages and items. This seemed to work fine until I followed a user link from the CB Online module and noticed that these modules didn't show for that or any profile.

The problem appears to stem from the fact that links from this module, and other links like you have identified, do not contain an Itemid=n.

My guess is that Joomla has no way of knowing if the requested page is related to a specific menu item or page. In this case Joomla should use the homepage module assignments, but obviously isn't.

The solution that worked for me was to assign my modules to the pages I desired, as well as the "unassigned" menu item link (instead of "all"). This tells Joomla that if no appropriate menu page relationship can be established, go ahead and publish those modules there.

So far this appears to be working brilliantly for me - hope it does for you as well.



i had never seen the unassigned , thanks so much , friggin aweome!

Please Log in to join the conversation.

13 years 11 months ago #55213 by msilver
OK this is a kluge, but there is still a significant problem: You can restore the modules with the "unassigned" option, but you still lose your menu location when you hit a cb profile link.

Any solution to that?

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.445 seconds

Facebook Twitter LinkedIn