cannot enter license code

10 years 4 months ago #95567 by redhubcap
I am using a 1and1 shared server business package
I have succesfully installed ioncube
I have successfully installed CB and its plugins
I have also followed the pdf installation instructions for CBsubs module
I am on page 57 of the pdf , the part where I click on the installed plugin
CB paid subscriptions
gives me this result

Error 500 - Internal server error

An internal server error has occured!
Please try again later.

I am unable to enter my license number for the site.
what should I do,

(sorry guys, or gals reading this, I realized I need to upgrade php to the latest version first then I will see if I have any errors)



thanks

Post edited by: redhubcap, at: 2009/04/19 20:48
10 years 4 months ago #95568 by redhubcap
found one problem by running ioncube file
it says I am running less than the recomended php version
so its time to figure out how to upgrade php on the server, then if anyproblems I will post.
10 years 4 months ago #95916 by alibroon
I have the same problem on a 1and1 uk business hosting package. Everything loaded fine and it wasn't till I went to enter the licence code that I got the 500 error.

I have done all the necessary checks
ioncube installed
PHP 5.2.9
CB 1.2 stable
Joomla 1.5.9

Permissions on the folders are fine and I have ran ioncube before with other plugins using the php.ini method with no problems.

Please help
10 years 4 months ago #95920 by beat
alibroon wrote:

I have the same problem on a 1and1 uk business hosting package. Everything loaded fine and it wasn't till I went to enter the licence code that I got the 500 error.

I have done all the necessary checks
ioncube installed
PHP 5.2.9
CB 1.2 stable
Joomla 1.5.9

Permissions on the folders are fine and I have ran ioncube before with other plugins using the php.ini method with no problems.

Please help


Maybe one of these FAQs could help find reason of the error 500:

www.joomlapolis.com/content/view/3949/58/
www.joomlapolis.com/content/view/3738/58/

Is it the General Settings form to enter license code that errors, or just after saving that form ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
10 years 4 months ago #95922 by alibroon
When I click on the Setting icon to enter my license number. I'll look at the faq's
10 years 4 months ago #96046 by alibroon
I have noticed that those having problems with entering their license are on 1and1 shared servers. Or is that just a coincedence.

With regards to my setup the ioncube loaders states it's working

This file has been successfully decoded. ionCube Loaders are correctly installed.

but I am still getting the error 500 when I click on the settings icon in the cb paid subscriptions plugin.

I have the php.ini and the file in the administrator root as well as my site root, and php.ini files in the ioncube folders.

Interestingly if I remove the php.ini file from the administrator root the cb paid subscriptions doesn't load and I get the message

The required free ionCube loader for your server type and php version is not installed. Please contact your hoster to install it for you, or visit ionCube free downloads page of ionCube loaders for the loader and instructions. In case of problems insalling the loader, please contact ionCube support directly after checking their support forum. Thanks.

Yet if I check ioncube-loader-helper.php
it tells me that An ionCube encoded file has been loaded successfully.:pinch:

Joomla 1.5.10
MySQL 5.1
PHP 5.2.9
Memory limit is set to 40M
Moderators: beatnantkrileon
Time to create page: 0.390 seconds