memory erros - php.ini has gobs of memory

11 years 5 months ago #120861 by ssamenfeld
memory erros - php.ini has gobs of memory was created by ssamenfeld
I'm trying to get CBSubs 1.0.3 running on Joomla 1.5.15 with CB 1.2.1.

We're in a hosted environment with a virtual dedicated server account that uses Sphera. It uses custom php.ini files (99user.ini)

Here are some of the server specifics:

Value

PHP Built on: Linux wholemusiclessons.com 2.6.9-89.0.18.EL.JLsmp #1 SMP Tue Dec 15 15:41:30 EST 2009 i686
Database Version: 5.0.67
Database Collation: utf8_general_ci
PHP Version: 5.2.2
Web Server: Apache/2.0.52 (Red Hat)
Web Server to PHP interface: apache2handler
Joomla! Version: Joomla! 1.5.15 Stable [ Wojmamni Ama Mamni ] 05-November-2009 04:00 GMT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)

I was able to get ioncube installed and enabled, etc. I have been able to install CBSubs. When setting up the first plan, I was able to do it by clicking on new and selecting the plan type. The new screen came up and I was able to fill it in and save it. I was even able to edit it briefly. Then the problem started to occur. My client was on the phone and trying to do it as well and she started reporting that she couldn'tedit or create new plans and was getting a blank page.

I've done a number of things to try to touble shoot:

Turned on Debug and checked to see what errosr were present and got the vollowing:

When trying to submit the registration form on the front-end instead of the paypal workflow it gives me a blank page with this error:

Fatal error: Out of memory (allocated 29360128) (tried to allocate 327043 bytes) in /var/www/html/wml/administrator/components/com_comprofiler/library/cb/cb.params.php on line 1071

From backend – admin

components/communitybuilder/plugins/paidsubs - when trying to edit or create new plans:

Fatal error: Out of memory (allocated 29884416) (tried to allocate 263622 bytes) in /var/www/html/wml/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/cbpaidsubscriptions.gui.php on line 0

Erro when trying to close in back-end...

Warning: mysql_query() [function.mysql-query]: Unable to save result set in /var/www/html/wml/libraries/joomla/database/database/mysql.php on line 223

Fatal error: out of dynamic memory in yy_create_buffer() in /var/www/html/wml/libraries/loader.php on line 140

Another error in back-end plugin:

Fatal error: Out of memory (allocated 27262976) (tried to allocate 19456 bytes) in /var/www/html/wml/components/com_comprofiler/plugin/user/plug_yancintegration/yanc.php on line 178

I've got all of the plugins installed but very few are enabled. I tried disabling all of the plugines except core and language plugins that wouldn't allow disabling. I also tried turning off the Joomla sef plugin and that made no difference.

I've increased the php memory to 256M from 128M. It shows up in phpinfo but the error persists.

I tried the apache setting in .htaccess that was in the forums. Made no difference.

I understand that the plans code is the most memory intensive but I can't imaging needing more than 256M.

I know that JFusion is installed but not configured. There are other applications like Docman, JEvents, etc.

Any ideas?

Thanks,

Scott

Post edited by: ssamenfeld, at: 2010/01/05 21:49

Please Log in to join the conversation.

11 years 5 months ago #120862 by Rapunzl
Replied by Rapunzl on topic Re:memory erros - php.ini has gobs of memory
The minimum PHP requirement is 5.2.6, but at least 5.2.10 is suggested (but not 5.3).

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction

Please Log in to join the conversation.

11 years 5 months ago #120863 by nant
ssamenfeld wrote:

Fatal error: Out of memory (allocated 29360128) (tried to allocate 327043 bytes)

Fatal error: Out of memory (allocated 29884416) (tried to allocate 263622 bytes)

Fatal error: Out of memory (allocated 27262976) (tried to allocate 19456 bytes)

I've increased the php memory to 256M from 128M. It shows up in phpinfo but the error persists.


Well it looks like something is not allowing needed memory allocation. Looks like you are only getting 30M.

Please Log in to join the conversation.

11 years 5 months ago #120864 by ssamenfeld
Replied by ssamenfeld on topic Re:memory erros - php.ini has gobs of memory
Rapunzel,

So it sounds like you are saying that I need to find out if my hosting service will upgrade php to 5.2.10 or at least to 5.2.6.

Thanks,

Scott

Please Log in to join the conversation.

11 years 5 months ago #120875 by krileon
Replied by krileon on topic Re:memory erros - php.ini has gobs of memory
ssamenfeld wrote:

Rapunzel,

So it sounds like you are saying that I need to find out if my hosting service will upgrade php to 5.2.10 or at least to 5.2.6.

Thanks,

Scott


That would be advised, but you've something eating all your memory. You need to increase your memory limit beyond 30mbs. I recommend 64mb for heavy sites (such as yours?).

Your memory limit is not updating because PHP.ini changes only adjust for the file the PHP.ini file is in. Try htaccess usage of changing memory limit if your host supports it as this will increase your memory limit site-wide.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 5 months ago #120954 by ssamenfeld
Replied by ssamenfeld on topic Re:memory erros - php.ini has gobs of memory
Some progress:

I uninstalled all of the cbsubs plugins and then reinstalled only the cbsubs main plugin and the system plugin. I can now edit and add new plans. I'm no longer getting out of memory erros. I'm not sure why uninstalling and reinstalling made a difference but it did.

Now when I enable both the cb plugin and the system plugin and go to the front-end and perform a registration I get a new error:

Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/html/wml/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/cbpaidsubscriptions.class.php on line 0

This looks like there is a different setting for the max execution time. Is this a php setting? What value should I try setting it to?

Thanks,

Scott

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.481 seconds

Facebook Twitter LinkedIn