Discrepancy between real sales & GoogleAnalytics

10 years 9 months ago #140692 by Ricksure
I have installed Google Analytics and setup the Analytics plugin with the appropriate tracking code. However Analytics is reporting far fewer sales than actually occurs. This makes it impossible to determine if the keywords I am using in Adwords are cost-effective.

For example in one week, Analytics reported 4 sales but I had actually made 20.

The fact that it is reporting something suggests that it is setup correctly but for some reason, most sales are not being recorded. Any thoughts?

Please Log in to join the conversation.

10 years 9 months ago #140755 by krileon
Google can take up to 24-48 hours to register a sale. Please if after a week no other transactions have been logged or your remaining purchase have not be logged let us know. Please also check that there are no Fatal JS errors on your site as they could prevent the Google API from working (is JS based). Please note only completed transactions will properly pass to Google.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

10 years 9 months ago #140791 by Ricksure
I have been monitoring this for a few weeks. The previous week was even worse. 51 real sales but only 5 showing in Analytics.

I don't see any errors in my logs.

By "completed transactions" do you mean sales that have been paid for as opposed to PayPal e-cheques? If so, note that almost no sales are by e-cheque.

The other thing that seems odd is the Analytics report that displays transactions and products. I only have one product at the moment so I would expect this figure to be the same. However "transactions" is double "products"

e.g. 10 Transactions; 5 purchased products.

Please Log in to join the conversation.

10 years 9 months ago #140812 by krileon
Interesting, could you provide some more detail as to what the difference is between those that ARE logged and those that AREN'T? Unsure of what the issue is exactly, will need to review the plugins code as more then likely Google has updated their API.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

10 years 9 months ago #140827 by krileon
Have reviewed the API and there seams to be some slight changes however the existing API should still work fine. Will be performing some tests to confirm if there is a problem or not, please be patient however as each test takes approx. 24 hrs before Google displays the results.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

10 years 9 months ago #140852 by Ricksure
krileon wrote:

Interesting, could you provide some more detail as to what the difference is between those that ARE logged and those that AREN'T?


I don't think I can. As I only have one product, there is no way for me to determine which sales were recorded in Analytics vs CB.

But here's something else to consider. The subscription I am selling has a one-time price of $14. However Analytics reports that the average order value is half - $7.

Now I have to admit that this is the first time I have used the ecommerce part of Analytics so there is every chance I have messed something up. But I can't see how as the figures are so different. I did create a goal that is supposed to record a sale and I wondered if this might cause a conflict. It is supposed to trigger if this URL is called: /index.php?option=com_comprofiler&cbpaidsubscriptionsbasket=31&cbpaidsubscriptionsgacctno=1&result=success

Anyway this doesn't seem to work so I have just turned it off and in the unlikely case that this makes a difference I will let you know.

I am happy to give you Administrator and Analaytics access if that helps.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.451 seconds

Facebook Twitter LinkedIn