[SOLVED] Redirected to 403 Error instead of CBSubs sign-on

10 years 9 months ago #142386 by zabalex2
Hello,

Please, help me. I'm trying to setup my first CBSubs website, but run into an issue. I tried reinstalling everything from scratch hoping that I messed something in the install or activation; however, I get the same issue again. I think it maybe something simple, such as ordering of plugins but cannot find anything in the documentation or other forums.

I'm using:
Joomla 1.5.18
CB 1.2.3
CBSubs 103
cbsubscontent plugin

To Reproduce:
The error doesn't happen if visitor first creates free login. To save the time, I created that user:
login: tester
password: tester
Website address is aircoalition.org.
Then, with that free login trying to click on the menu link to view the article of a premium section protected by the content plugin, the user is given an option to upgrade to sufficient level of membership to be able to access that article - just like I wanted!
However, if the user visiting the page for the first time, clicking on that same menu item to view premium content, he/she is recirected to the 403 error page. With the debugging information turned-on, I get the following error:

On that website, there's menu item on the left: "Form C 101". I will provide login on request if needed.

403 - You are not authorised to view this resource
You may not be able to visit this page because of:

1.an out-of-date bookmark/favourite
2.a search engine that has an out-of-date listing for this site
3.a mistyped address
4.you have no access to this page
5.The requested resource was not found.
6.An error has occurred while processing your request.
Please try one of the following pages:


•Home Page

If difficulties persist, please contact the System Administrator of this site.

You are not authorised to view this resource.


Call stack
# Function Location
1 JSite->dispatch() /home/alickac/public_html/index.php:68
2 JComponentHelper->renderComponent() /home/alickac/public_html/includes/application.php:124
3 require_once() /home/alickac/public_html/libraries/joomla/application/component/helper.php:162
4 JController->execute() /home/alickac/public_html/components/com_content/content.php:35
5 ContentController->display() /home/alickac/public_html/libraries/joomla/application/component/controller.php:236
6 JController->display() /home/alickac/public_html/components/com_content/controller.php:55
7 JCacheView->get() /home/alickac/public_html/libraries/joomla/application/component/controller.php:308
8 ContentViewArticle->display() /home/alickac/public_html/libraries/joomla/cache/handler/view.php:98
9 JView->get() /home/alickac/public_html/components/com_content/views/article/view.html.php:40
10 ContentModelArticle->getArticle() /home/alickac/public_html/libraries/joomla/application/component/view.php:364
11 JError->raiseError() /home/alickac/public_html/components/com_content/models/article.php:144
12 JError->raise() /home/alickac/public_html/libraries/joomla/error/error.php:171
13 JException->__construct() /home/alickac/public_html/libraries/joomla/error/error.php:136


Some info about my Environment::
System Information & Setting Value

PHP Built on: Linux nicole.ndx9.com 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:32:21 EST 2010 x86_64
Database Version: 5.0.90-community-log
Database Collation: utf8_general_ci
PHP Version: 5.2.9
Web Server: Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
Web Server to PHP interface: cgi
Joomla! Version: Joomla! 1.5.18 Stable [ wojmamni ama wojnaiki ] 27-May-2010 18:00 GMT
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.5; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 1.1.4322; .NET CLR 3.5.30729; InfoPath.2; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; NET_mmhpset)

Relevant PHP SettingsSetting Value

Safe Mode: Off
Open basedir: None
Display Errors: On
Short Open Tags: On
File Uploads: On
Magic Quotes: On
Register Globals: Off
Output Buffering: On
Session Save Path: /tmp
Session Auto Start: 0
XML Enabled: Yes
Zlib Enabled: Yes
Disabled Functions: None
Mbstring Enabled: Yes
Iconv Available: Yes
WYSIWYG Editor: Editor - No Editor

Post edited by: zabalex2, at: 2010/09/18 20:34

Post edited by: zabalex2, at: 2010/09/19 02:10

Post edited by: krileon, at: 2010/09/21 15:10

Please Log in to join the conversation.

10 years 9 months ago #142447 by krileon
Does unpublishing CBSubs cause the page to load? Seams there's a permissions issue in place or something of the sort. Please ensure CBSubs, its tab, and its Joomla bot are Public. Also check the menu link associated with Itemid 56 to ensure permissions configured correctly. Please also upgrade to Joomla 1.5.20 as you're out of date. The issue does not seam related to CBSubs, please see search results below.

lmgtfy.com/?q=403+-+You+are+not+authorised+to+view+this+resource .

Post edited by: krileon, at: 2010/09/20 15:49


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

10 years 9 months ago #142514 by zabalex2
Krileon,

Thanks a lot for your update. This is presicely the kind of information that I needed. To the point. I first unpublished all cb, cbsubs, but still had issue. Sorry, since I'm new to this plugin things, I now know how to debug something like that.
1 unpublish. - didn't work
2 upgrade from 1.5.17 to 1.5.20 - didn't work
3 checked all permissions. Re-enabled all plugins - YAHOO!

Thanks again, my site finally works.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.404 seconds

Facebook Twitter LinkedIn