[#1720] Display main menu on left

11 years 11 months ago #135402 by krileon
Replied by krileon on topic Re:Display main menu on left
After making the core code adjustments have you ensured the registration menu link you created is selected within the module to be shown on that menu link? Please also ensure the link is published and public (it's module does not have to be present). Based off the Itemid specified your link should be as follows.

[code:1]
index.php?option=com_comprofiler&task=registers&Itemid=127
[/code:1]

We will be addressing the issue of missing Itemids with next CB release (1.2.3) as have extended the cbitemid API to allow checking for other links itemids.

Post edited by: krileon, at: 2010/06/11 17:28


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 11 months ago #135416 by DreamRaven
Replied by DreamRaven on topic Re:Display main menu on left
I am not 100% sure I understand your terminology, but I will have a go:

registration menu link? It is published and public (see attached screenshot.

From within the mainmenu module, that link is selected to display it. (also see screenshot)

I have added that code to the end of my domain and it gives a Joomla! 404 response

Attachments:

Please Log in to join the conversation.

11 years 11 months ago #135439 by krileon
Replied by krileon on topic Re:Display main menu on left

I have added that code to the end of my domain and it gives a Joomla! 404 response

Added what code? All you're doing is adding an Itemid to the Register link within the CB Login module. Then when clicking such a link your modules associated with that Itemid should display. Have confirmed this working on numerous installs. Please disable all SEF and confirm if then working.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 11 months ago #135543 by DreamRaven
Replied by DreamRaven on topic Re:Display main menu on left
OK

Late friday typo in adding link to domain...

Have tried with SEF on and off, link works, BUT still no mainmenu module displaying when visiting link. ONLY modules with 'display on all pages' setting display on that page

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.137 seconds

Facebook Twitter LinkedIn