[#1720] Display main menu on left

11 years 11 months ago #134267 by krileon
Replied by krileon on topic Re:Display main menu on left
The Itemid you add needs to match a Joomla menu link, that Joomla menu link can then be configured via the module to show the module on that menu link. You need to then edit the URL and add that Itemid. Another option is use CB Registration Joomla menu links and hide the modules registration link via CSS or something of the sort.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 11 months ago #135248 by DreamRaven
Replied by DreamRaven on topic Re:Display main menu on left
I think that there is a little talking at cross purposes here. I am finding what I think the original poster is having as a problem.

This is the first post when I searched on my issue.

I have a similar situation, where there are a couple of pages on the site where I do not want the main menu to display, so the main menu module has been set to only show on selected menu items rather than 'all' or 'none'.

This then dominoes down that when you visit a number of CommunityBuilder or 'comprofiler' pages the menu does not display, but I want it to. These pages do not exist in any menu so I cannot select them and ask the main menu module to display. The URLs that I am worried about are:

www.mydomain.com/component/comprofiler/login
www.mydomain.com/component/comprofiler/registers
www.mydomain.com/component/comprofiler/

I have tried making menu items for these pages and assigning the main menu module to them, but this has no effect...

So, there is no 'menu id' to apply to whatever code hack has been previously mentioned.

I hope I have explained clearly...

Please Log in to join the conversation.

11 years 11 months ago #135249 by alimbolar
Replied by alimbolar on topic Re:Display main menu on left
you got that right!!..;-)..

I kinda gave up and found some compromising method to make it look right (I displayed the menu on all pages)..

Let me know if you figure this out..

Regards,
Alim

Please Log in to join the conversation.

11 years 11 months ago #135272 by krileon
Replied by krileon on topic Re:Display main menu on left
Folks, the only locations that Itemid are NOT added and considered is and only is the Login module. Editing the core code is necessary to add those Itemids. We are reviewing fixing this and adding them for CB 1.2.3 to avoid anymore issues. Have added a bug ticket (am considering this a bug) for issue to be addressed, sorry for the inconvenience.

#1720

Post edited by: krileon, at: 2010/06/10 20:15


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 11 months ago #135346 by DreamRaven
Replied by DreamRaven on topic Re:Display main menu on left
OK...

But I still do not understand what you are trying to say!

Does the ItemId have something to do with being able to show a menu/module? If they do, and and core code hack is necessary, what happens if the ItemId of the menu item changes at any point in the future? I guess that is part of the bug fix...

As stated, it doesn't happen ONLY on the login page, it happens on the register page too.

I tried changing the settings on another Joomla/CB site that I have and turning off the menu on a couple of pages ensures that it doesn't show on any of the comprofiler login or register pages.

I am going to follow your instructions from earlier to add and 'ItemId' somewhere, and see what happens.

Please Log in to join the conversation.

11 years 11 months ago #135349 by DreamRaven
Replied by DreamRaven on topic Re:Display main menu on left
I have followed the instructions, but in my installation the line is 836.

Adding the code appears to have no noticeable effect whatsoever.

I have added a screenshot which groups images from the backend, a shot from the code, and comparative page images from the front end of the site, being the front page with appearing main menu module (which has 'varies' pages choice) and the CB register page which the main menu does not appear on.

It is worth noting that the modules that do appear on the register page all have their page setting to 'All'

It is a coincidence that my main menu appears on the left in my installation, but the issue is still the same.



Post edited by: DreamRaven, at: 2010/06/11 14:00

Post edited by: DreamRaven, at: 2010/06/11 14:27
Attachments:

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.199 seconds

Facebook Twitter LinkedIn