By URL parts does not work

8 years 5 months ago #147611 by antohoho
Hi guys,

I have problem with Content Protection Plugin.

1. I see error message like this: The needed mambot/plugin 'cbpaidsubsbot' is not installed. when I go to the Integration Tab -> Extensions (It's installed and enabled)

2. I am trying setup 'By URL parts' but it still not working. I added next link that must be block for CBSubs plan - option=com_comprofiler&task=pluginclass&plugin=cbgroupjive&action=groups&func=new&cat=1&Itemid=100065 it's a full link to this page (I was trying various) - but user still can view this page..

What's wrong with 'By URL parts'?
8 years 5 months ago #147613 by drdehart
Anton is working on our team (we are the paid CBsubs subscriber). We are trying to implement a method that was suggested for blocking menu links in the GroupJive working group.
Having problems getting it to work.
8 years 5 months ago #147641 by nant
antohoho wrote:

Hi guys,

I have problem with Content Protection Plugin.

1. I see error message like this: The needed mambot/plugin 'cbpaidsubsbot' is not installed. when I go to the Integration Tab -> Extensions (It's installed and enabled)

2. I am trying setup 'By URL parts' but it still not working. I added next link that must be block for CBSubs plan - option=com_comprofiler&task=pluginclass&plugin=cbgroupjive&action=groups&func=new&cat=1&Itemid=100065 it's a full link to this page (I was trying various) - but user still can view this page..

What's wrong with 'By URL parts'?


issue 1: If using CBSubs 1.1 this is a cosmetic bug that will be addressed with new release asap but can be ignored for now.

issue 2: no need to have itemid part in the URL part.
8 years 5 months ago #147674 by drdehart
Thanks Nick,
Are you are saying that you think it is the presence of the itemID that is causing the function to fail and that if we remove that it will then work properly?

BTW - we neglected to post this information, sorry:

1.Exact PHP version. - 5.2.14
2.Exact CB version. - 1.3
3.Exact Joomla version. - 1.5.22
4.Detailed description of problem. (screenshots? link?) - see original post
5.Any error messages reported with Joomla debug mode on and error reporting set to maximum? - see original post
6.Any error messages reported with your hosts error log? - We should check and post with the next message if it is still not working.
7.Any ACL modification components? (JACL, etc..) - no
8.Any SEF components?- SH404sef, but disabled.
9.Move or encrypt configuration.php? - no
10.Upgrade from CB version ?? or fresh install? - upgraded from 1.2.3
11.Migrated from Joomla version ?? or fresh install? - migrated from 1.5.20

Post edited by: drdehart, at: 2010/12/03 15:09
8 years 5 months ago #147686 by nant
antohoho wrote:

2. I am trying setup 'By URL parts' but it still not working. I added next link that must be block for CBSubs plan - option=com_comprofiler&task=pluginclass&plugin=cbgroupjive&action=groups&func=new&cat=1&Itemid=100065 it's a full link to this page (I was trying various) - but user still can view this page..

What's wrong with 'By URL parts'?


the &itemid=100065 is not needed.

to debug for yourself try and protect the URL part then compare to the URL you feel is not being protected and see the differences.

Also turn SEF off during test (just to make sure SEF isn't causing problem)
8 years 5 months ago #147696 by antohoho
I was trying various URL parts, but it still not working.

It was:

1. option=com_comprofiler&task=pluginclass&plugin=cbgroupjive&action=groups&func=new&cat=1&Itemid=100065

2. option=com_comprofiler&task=pluginclass&plugin=cbgroupjive&action=groups&func=new&cat=1

3. option=com_comprofiler&task=pluginclass&plugin=cbgroupjive&action=groups

4. option=com_comprofiler&task=pluginclass

But nothing changed..

And SEF is off.
Moderators: beatnantkrileon
Time to create page: 0.393 seconds
Facebook Twitter Google LinkedIn