hidden fields are shown for plan

8 years 5 months ago #148175 by serjo
When I directly link to a registration page for a plan with hidden fields, these fields show up anyway.
When I use the "standard" registration form that shows all plans on one page, the hidden fields don't show up.

This would be the direct link for example: index.php?option=com_comprofiler&task=pluginclass&plugin=cbpaidsubscriptions&do=displayplans&plans=3

Can someone confirm this as a bug?


I use CB 1.3.1 and CBsubs 1.1, no SEF URLs on a local php 5.29

Just updated to CBsubs 1.1.1 - problem still persist...

Post edited by: serjo, at: 2010/12/09 01:57

Post edited by: serjo, at: 2010/12/09 02:22

using:
CB v2.0.x
CBsubs v 4.1.x
Joomla 3.3+
8 years 5 months ago #148273 by krileon
I could not confirm this. Please ensure the plan you're linking to is the plan that hide fields. It's possible there's a misunderstanding of the hide fields on registration feature.

I have Plan A for example that hides Field 1. If I navigate to Plan As URL then Field 1 is not visible. If I navigate to Plan 1 and Plan 2 URL then Field 1 IS visible until I select Plan 1 (same as seen on registration).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 years 5 months ago #148287 by serjo
It did work as long as I only had 2 plans. When I added the 3rd plan, things went wrong.

I will test this on the actual server today and keep you updated.

using:
CB v2.0.x
CBsubs v 4.1.x
Joomla 3.3+
8 years 5 months ago #148292 by serjo
Hi,

the problem also exists on the live server. You can check it out here: smartwebhosting.co.nz/cbtestsite/

When you click on the "Register" menu, you can see the working forms with the correct hidden fields when you switch between registrations. But when you use the direct URL as in "Register as a tourist" you can still see the fields that should be hidden for that plan.

using:
CB v2.0.x
CBsubs v 4.1.x
Joomla 3.3+
8 years 5 months ago #148363 by krileon
Appears to be something mis-configured with your Host and Tourist plans. Notice the plan is not visible and not selected on the registration page after clicking its URL. Also notice when using the Club URL the plan is available at fields hidden fine. Please check the Workflows of those two plans to ensure it's properly configured. Please also check the Access tab to ensure the permissions is not blank and set to Everyone.

Post edited by: krileon, at: 2010/12/10 19:23


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
8 years 5 months ago #148380 by serjo
this is definitely a bug... even when I copy an existing plan, that displays the correct fields and then click on it's URL, it show all fields and does not hide any.
just try it...take an exiting plan (with some hidden fields), make a copy of it, publish it and then go to it's URL.

Thank you for looking into this.

using:
CB v2.0.x
CBsubs v 4.1.x
Joomla 3.3+
Moderators: beatnantkrileon
Time to create page: 0.401 seconds
Facebook Twitter Google LinkedIn