Add Connection in User Menu

10 years 7 months ago #149359 by T77HAS
Add Connection in User Menu was created by T77HAS
I have been pulling my hair out for the last few hours trying to create a User Menu link that will enable "Add Connections".

I have also tried creating a field delimiter with [user_id] but this link just gives me an error saying "This user no longer exists" any help will be very appreciated.

Please Help.

Please Log in to join the conversation.

10 years 7 months ago #149382 by krileon
Replied by krileon on topic Re:Add Connection in User Menu
User Menu? It's not possible to add such a link to a Joomla menu as it has dynamic variables (userid). In order to add it as a delimiter field link you'd need to use the following content.

[code:1]
<a href="index.php?option=com_comprofiler&act=connections&task=addConnection&connectionid=[cb:userdata field="user_id" user="#displayed" /]">Add Connection</a>
[/code:1]


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

10 years 7 months ago #149413 by T77HAS
Replied by T77HAS on topic Re:Add Connection in User Menu
I tried that but still getting "This profile does not exist or is no longer available"

Does cb userdata need changing?

Please Log in to join the conversation.

10 years 7 months ago #149515 by krileon
Replied by krileon on topic Re:Add Connection in User Menu
Examine the source and copy and paste the link that is being generated. Try using just [user_id] instead of [cb:userdata
field="user_id" user="#displayed" /]. Where are you trying to display this? You must be adding the content to a Delimiter field. You also need to have the Connections plugin published. You'll also need connections enabled within CB Configuration.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.465 seconds

Facebook Twitter LinkedIn