CB Auto Actions - joomla_Onuserlogin event not Triggered ?

9 months 3 days ago - 9 months 3 days ago #320514 by smalldragoon
Hi,
I just installed a SAML SSO login to my website on top of CB. ( for ref : plugins.miniorange.com/joomla-single-sign-on-sso )
This plugins works as I'm logged in BUT the behavior is strange from my point of view : it seems that there is no joomla_OnUserlogin triggered ( nor joomla_onAfterlogin etc...)
Thus, the cookie "Joomla_user_state" is not created as well.
Of course, everything is working properly with "normal" login


My first guess is that this SSO plugin is not developped triggering J! Events ? Is this possible and would make sense ?

If so , how could I tweak something to have actions triggered at login ?
Thanks

Please Log in to join the conversation.

9 months 3 days ago #320532 by krileon
I can't help you with paid products without an active subscription. My best guess is the extension you're using is not firing any Joomla events for whatever reason.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: smalldragoon

Please Log in to join the conversation.

9 months 23 hours ago #320556 by smalldragoon
Hi, that was my though as well.
Thanks a lot ! ( and make sense for the support, will contact them ...)
Lionel
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

8 months 4 weeks ago #320643 by smalldragoon
Hi,
For benefits of the forum, the issue was indeed that no Joomla event was fired, therefore, no trigger(s) were launched.
Thx
The following user(s) said Thank You: nant, krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.413 seconds

Facebook Twitter LinkedIn