[SOLVED] Mail malfunction

4 months 3 days ago - 3 months 3 weeks ago #324782 by MSpina59
[SOLVED] Mail malfunction was created by MSpina59
Hi everybody.
I'm facing some problems with the feature "Send a message via email" (see picture). I didn't find anything in the forum matching exactly my problem: using that form the mail never arrives (although the message "Your email was sent successfully!" is shown), while sending mail from the mass mailing function in the back-end works properly, as well as the connection requests.
For the sake of completeness: the problem is the same either using PHPMail and SMTP.
Any suggestion highly appreciated, at least on how to setup and retrieve logs...:)
Many thanks in advance.
Marco
Site infrastructure : Joomla! 3.9.26 / CB 2.6.0 / PHP 7.4.16
Attachments:

Please Log in to join the conversation.

4 months 16 hours ago #324808 by krileon
Replied by krileon on topic Mail malfunction
We don't keep logs of emails. That'd be for your host and/or your mailserver to do. Do registration emails send fine? Ensure the form email address within CB > Configuration > Registration is valid and matches the domain of your mailserver.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 13 hours ago #324823 by MSpina59
Replied by MSpina59 on topic Mail malfunction
Self-registration is not allowed on my site, so I keep the default values on the Registration tab, see the picture.
Should I put something there?
As I said already, the mass mailing function works properly, as well as the Connection requests, in case this got anything to deal with the issue.

Marco


Attachments:

Please Log in to join the conversation.

4 months 13 hours ago #324824 by krileon
Replied by krileon on topic Mail malfunction
If you're seeing "Your email was sent successfully!" with no errors then that means the API didn't get an error response from the mail server. My guess is your mail server is blocking the sending of the emails. Contact whoever is in charge of your mail server (usually your web host) and see if they can check outbound logs.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 4 weeks ago #324830 by MSpina59
Replied by MSpina59 on topic Mail malfunction
I beg your pardon Kyle, but considering that:
  • the behaviour is the same either with PHPMail and an SMTP server (hosted by Aruba.it)
  • mass mailing works fine
  • connection requests work fine
  • the Joomla! standard test mail works fine
  • JEM events registration mail work fine
how can it be a mail server issue?
Is there a way to "see" what the form "Send message via mail" actually sends to the mail server?
Maybe a parameter gets corrupt, e. g. the "To" field, resulting in values formally correct, but actually wrong.

Please Log in to join the conversation.

3 months 4 weeks ago #324836 by krileon
Replied by krileon on topic Mail malfunction

how can it be a mail server issue?

The mail server may not like the contents of the email. This happens sometimes if an outbound spam filter is applied for example. Some hosts apply one to prevent abuse. Again, contact your host and have them check. Attempt to send a test email and provide them the subject and body of your test email using the email form as well as the recipients email address (whatever is set within that users account) so they can see if it even reached them. There isn't really a reason code wise for some emails in CB to work and not that one as they all use the same API to send emails.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.232 seconds

Facebook Twitter LinkedIn