Apache server crashes of easyphp when editing Community Builder 2.09 localhost

4 years 2 months ago #266862 by jjsjjs
Hello,

i don't know why, but when working on localhost using Easyphp devserver 14.1vc11 using apache 2.4.7/php 5.6.4/mysql 5.6.15 and joomla 3.4.3 and am editing something from Community Builder for example the Users List then Apache server crashes.
But only when doing editing on Community Builder. Nowhere else as far as i noticed.

Any clou?
Please see below Apache error log (i cleared the error log and waited until i happened again so this is the actual error when it happened)

[Sun Jul 05 19:34:21.446121 2015] [core:notice] [pid 676:tid 220] AH00094: Command line: 'J:\\server\\EasyPHP-DevServer-14.1VC11\\binaries\\apache\\bin\\eds-httpd.exe -d J:/server/EasyPHP-DevServer-14.1VC11/binaries/apache'
[Sun Jul 05 19:34:21.446121 2015] [mpm_winnt:notice] [pid 676:tid 220] AH00418: Parent: Created child process 7216
[Sun Jul 05 19:34:22.709723 2015] [mpm_winnt:notice] [pid 7216:tid 228] AH00354: Child: Starting 64 worker threads.
[Sun Jul 05 19:34:29.008535 2015] [mpm_winnt:notice] [pid 676:tid 220] AH00428: Parent: child process 7216 exited with status 3221225725 -- Restarting.
[Sun Jul 05 19:34:29.133335 2015] [mpm_winnt:notice] [pid 676:tid 220] AH00455: Apache/2.4.7 (Win32) PHP/5.6.4 configured -- resuming normal operations
[Sun Jul 05 19:34:29.133335 2015] [mpm_winnt:notice] [pid 676:tid 220] AH00456: Apache Lounge VC11 Server built: Nov 21 2013 20:13:01
[Sun Jul 05 19:34:29.133335 2015] [core:notice] [pid 676:tid 220] AH00094: Command line: 'J:\\server\\EasyPHP-DevServer-14.1VC11\\binaries\\apache\\bin\\eds-httpd.exe -d J:/server/EasyPHP-DevServer-14.1VC11/binaries/apache'
[Sun Jul 05 19:34:29.133335 2015] [mpm_winnt:notice] [pid 676:tid 220] AH00418: Parent: Created child process 6536
[Sun Jul 05 19:34:29.991337 2015] [mpm_winnt:notice] [pid 6536:tid 232] AH00354: Child: Starting 64 worker threads.

Any help on this will be appreciated, i will do also a google search and of course if i find the solution i will post it. I just don't want this to happen on a live site.

Thanks a lot.
4 years 2 months ago - 4 years 2 months ago #266863 by jjsjjs
Ok allready quickly found the solution. :woohoo:
Seems to happen on windows machines

Found on this link.
apache solution

edit the httpd.conf file and add the lines below
restart easyphp or other xamp/wamp server and it is solved.

<IfModule mpm_winnt_module>
ThreadStackSize 8888888
</IfModule>
Moderators: beatnantkrileon
Time to create page: 0.356 seconds
Facebook Twitter Google LinkedIn