CB_Login logout redirect

4 years 1 month ago - 4 years 1 month ago #268106 by rolandfrancis
1. Nant, please do not use the login module for once.
Now check your functionality using the *menu settings of your CB menu* options.
You will notice that when you make a menu redirect to CB login via menu, the "first-login-redirect does *not* work as it should.

Bottom line: the work-around solution for all 3 points (see up in thread) is to *not* use the menu options of CB menu and ONLY use the CB login module for login/logout functionality.

4. I must recall my point 4, since I changed the password minimal requirements myself (user menu options of core Joomla) Sorry for that.
4 years 1 month ago #268107 by nant

rolandfrancis wrote: 1. Nant, please do not use the login module for once.
Now check your functionality using the *menu settings of your CB menu* options.
You will notice that when you make a menu redirect to CB login via menu, the "first-login-redirect does *not* work as it should.

Bottom line: the work-around solution for all 3 points (see up in thread) is to *not* use the menu options of CB menu and ONLY use the CB login module for login/logout functionality.

4. I must recall my point 4, since I changed the password minimal requirements myself (user menu options of core Joomla) Sorry for that.


I did the following test:

CB Configuration -> Registration tab -> First Login Redirect is set to:

index.php?option=com_comprofiler&view=userprofile

(means that first ever login should take user to his/her profile page).

Then used a CB Login menu for login process and the first login redirect worked just fine.

>> You will notice that when you make a menu redirect to CB login via menu, the "first-login-redirect does *not* work as it should.

What exactly do you mean here?
What did you create?
4 years 1 month ago #268110 by rolandfrancis
Hi nant,

To be of service, I created the following:
I have setup a clean J3.4.3 with CB 2.0.10 on www.pythias.eu

To illustrate the bug:
- I have created a menu with a LOGIN button for guests --> CBmoduleredirect to /welcome-to-you
- And a menu item with LOGOUT for registered users ==>CBlogin-moduleredirect to www.csi-tools.com/contact

When you click the menu-logout you will see the bug
(ONLY when you click the logout button on the CBloginmodule, it works as expected)

I hope this helps you to replicate

user: Test1
password: Test1

Also *1*: try to create a new account and notice that *first login redirect* does not work (you arrive on homepage) and *not* on firstlogin settings of CB configuration NOR on login redirect as set in CBlogin module.

If you would like an super user login, pls PM me.
4 years 1 month ago #268117 by nant

rolandfrancis wrote: Hi nant,

To be of service, I created the following:
I have setup a clean J3.4.3 with CB 2.0.10 on www.pythias.eu

To illustrate the bug:
- I have created a menu with a LOGIN button for guests --> CBmoduleredirect to /welcome-to-you
- And a menu item with LOGOUT for registered users ==>CBlogin-moduleredirect to www.csi-tools.com/contact

When you click the menu-logout you will see the bug
(ONLY when you click the logout button on the CBloginmodule, it works as expected)

I hope this helps you to replicate

user: Test1
password: Test1

Also *1*: try to create a new account and notice that *first login redirect* does not work (you arrive on homepage) and *not* on firstlogin settings of CB configuration NOR on login redirect as set in CBlogin module.

If you would like an super user login, pls PM me.


Sure - PM me sa access and I will see how you configured things.
Moderators: beatnantkrileon
Time to create page: 0.387 seconds
Facebook Twitter Google LinkedIn