CB_Login logout redirect

4 years 4 weeks ago #268011 by cosimota

nant wrote:

cosimota wrote:

nant wrote: what logout redirect are you using?


In CB_Login|Logout Options:
Logout Redirection URL = "mnuPageToRedirect"

In User Menu:
Menu item type = "User Logout" (from CB ),
Link = "index.php?option=com_comprofiler&view=logout"

I hope I have understood your request and responded correctly.


What logout URL are you puting in the CB Login module?


The site is: www.transalppuglia.it
The logout page where to go is: www.transalppuglia.it/mnuhome
The logout URL I put in the CB Login module is: mnuhome

All works fine if I don't use the logout item in the menu user.
4 years 4 weeks ago #268012 by nant

cosimota wrote:

nant wrote:

cosimota wrote:

nant wrote: what logout redirect are you using?


In CB_Login|Logout Options:
Logout Redirection URL = "mnuPageToRedirect"

In User Menu:
Menu item type = "User Logout" (from CB ),
Link = "index.php?option=com_comprofiler&view=logout"

I hope I have understood your request and responded correctly.


What logout URL are you puting in the CB Login module?


The site is: www.transalppuglia.it
The logout page where to go is: www.transalppuglia.it/mnuhome
The logout URL I put in the CB Login module is: mnuhome

All works fine if I don't use the logout item in the menu user.


I tested locally and logout redirect seems to work

I put full URL - for example: http://localhost:8888/JPDEMO/index.php/forum/recent
4 years 4 weeks ago #268013 by cosimota

nant wrote: I tested locally and logout redirect seems to work

I put full URL - for example: http://localhost:8888/JPDEMO/index.php/forum/recent


I'm sorry, I know that it works properly. But this happens because I dont'use the User Menu.

A curiosity: how did you test if you are not a registered user?
4 years 4 weeks ago #268016 by nant

cosimota wrote:

nant wrote: I tested locally and logout redirect seems to work

I put full URL - for example: http://localhost:8888/JPDEMO/index.php/forum/recent


I'm sorry, I know that it works properly. But this happens because I dont'use the User Menu.

A curiosity: how did you test if you are not a registered user?


I tested on my local site.

I configured CB Login module to redirect on logout.
Then logged in from frontend and then clicked on the logout button on the frontpage login module and it redirected me as expected.

No bug.
4 years 4 weeks ago #268022 by cosimota
Nick, thank you for your evidence. I confirm what you say. But it has nothing to do with the problem that complained ... please review previous messages better.
4 years 4 weeks ago #268023 by nant

cosimota wrote: Nick, thank you for your evidence. I confirm what you say. But it has nothing to do with the problem that complained ... please review previous messages better.


On a clean CB 2.0.10 install there is a community builder menu created with all CB related joomla menus.

I did not create any new menu item and the logout redirect works just fine.

Sorry I am not understanding the issue.

If you can replicate on a clean Joomla 3.4 / CB 2.0.10 site and give exact steps to reproduce I will take another look.
Moderators: beatnantkrileon
Time to create page: 0.391 seconds
Facebook Twitter Google LinkedIn