Sender email is wrong

4 years 3 weeks ago - 4 years 3 weeks ago #269491 by Yxos
We just upgraded to CB 2.0.10 and found a difference to the older version.

When a user utilizes the option to write an email to another user, using the form designed for this purpose (/emailuser?), the email arrives at the other user with a comment at the bottom of the email saying that the user should be carefull when replying to the email because that will reveal his real email to the first user, because replying will use the email sender address; which is the real email address of the first user.

This is an excellent way of handling email privacy!
However, on 2.0.10, the email sent to the second user does NOT have the first users email address as sending address. Instead the Joomla site address is used, causing that an eventual reply will probably go to the site webmaster.

Is this a bug in 2.0.10, or is there a setting I have missed?

Yxos
4 years 3 weeks ago #269496 by nant

Yxos wrote: We just upgraded to CB 2.0.10 and found a difference to the older version.

When a user utilizes the option to write an email to another user, using the form designed for this purpose (/emailuser?), the email arrives at the other user with a comment at the bottom of the email saying that the user should be carefull when replying to the email because that will reveal his real email to the first user, because replying will use the email sender address; which is the real email address of the first user.

This is an excellent way of handling email privacy!
However, on 2.0.10, the email sent to the second user does NOT have the first users email address as sending address. Instead the Joomla site address is used, causing that an eventual reply will probably go to the site webmaster.

Is this a bug in 2.0.10, or is there a setting I have missed?


Please check your CB -> Configuration -> General tab settings:

Emails Sent From parameter.
4 years 3 weeks ago #269499 by Yxos
There it was :)
Thank you!

Yxos
4 years 1 week ago #270170 by azjr
@Nick: I just found this post after updating my own post here: www.joomlapolis.com/forum/153-professional-member-support/231080-wherehow-to-modify-email-template-sent-from-user-to-user-front-end

I have tested both options for that parameter and in both cases the email address is sent form email specified in Joomla Configuration (site/admin email) - J3.4.3 and CB 2.0.10
I'm curious how did it work for @Yxos - I do believe this is rather a bug - thanks!
3 years 11 months ago #271186 by Yxos
It worked fine because there is a difference between email-from and reply-to-email.

Yxos
Moderators: beatnantkrileon
Time to create page: 0.728 seconds