[#7042] How to install CB in joomla 3.8.5 with php 7.2.1 ?

1 year 6 months ago - 1 year 6 months ago #302140 by sebpl
Hi,
I am trying to install community builder in local on joomla 3.8.5 with php 7.2.1.
Take care that is it not an update, I have not yet community builder installed.

I have the following message if I use the web instalator:

Fatal error: Cannot use result of built-in function in write context in libraries\CBLib\CB\Legacy\Archive_Tar.php on line 687

If I download the last version of CB: 2.1.3+buid 2018.02.16.15.00.00.4929f8942 (latest) and I use the package instalation I have the same message:
Fatal error: Cannot use result of built-in function in write context in libraries\CBLib\CB\Legacy\Archive_Tar.php on line 687

It mean that I can't install CB with php 7.2.1 ?
1 year 6 months ago - 1 year 6 months ago #302188 by krileon
It's the packaged plugin tar file causing that and looks like a bug in Archive_Tar that appears fixed and have added a bug ticket to update our Archive_Tar usage.

forge.joomlapolis.com/issues/7042


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 year 6 months ago #302195 by krileon
Ok, new build has been released with an up to date Archive_Tar library. Tested working install on PHP 7.2.1.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.665 seconds
Facebook Twitter Google LinkedIn