Search with "No preference" giving nothing

4 months 1 week ago - 4 months 1 week ago #309825 by ZeNono
Joomla 3.9.1
Community Builder 2.4.0
PHP 7.2.10 / MYSQL 5.5.5-10.1.34-MariaDB-0ubuntu0.18.04.1

On a website in Dutch, I have one searchable field with 4 possible values.
For a search, I get the additional vale "No preference" ("Geen voorkeur").

When I'm selecting on of those value where there is no result, I'm getting indeed the message there is no result.


But when I'm selecting "No preference", it displays the searchable fields with nothing selected, but there is no result and there isn't even any message saying there is no result.


Can it come from a wrong configuration or is it a potential bug?
Attachments:
4 months 1 week ago #309835 by krileon
No preference just clears the search for that input. It should display as if you didn't search that input. If you don't allow empty searches then what you're seeing is normal since empty search will result in no user output.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 months 1 week ago #309848 by ZeNono
Ok.

I was thinking that "No preference" means "Any value is good" even empty field.

By the way, "Hide empty searches" is set to No. Actually, whether I set it to Yes or No gives me the same behaviour: I get nothing.
4 months 1 week ago #309864 by krileon
Your userlist is likely always empty then. Ensure the "Usergroups" parameter in your userlist has the appropriate usergroups selected as that determines who it's allowed to display based off their usergroups.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
4 months 1 week ago #309879 by ZeNono
I can do searches that get results so I don't think it's linked to the usergroups.
4 months 1 week ago #309918 by krileon
I'm not seeing any issues with selecting "No preferences" for a multiselect then searching. It should clear the selection and clear the search criteria if it's the only criteria then display as if no search was made. Review the URL in your browsers address bar as search criteria should be listed there if searching is being applied and you should see a "List All" button to clear the criteria.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.500 seconds
Facebook Twitter Google LinkedIn