[#2912] GroupJive 2.4 | Class 'cbgjAuto' not found

9 years 1 day ago #180199 by krileon

Are all those patches in the "foundation" file?

No, I've fixed numerous files all throughout CB.

If not, could you provide an un-official release of CB 1.7.1 ?

No, you'll need to wait for next release.

I can't advise anything further without reviewing for my self. Please PM backend super administrator login credentials and will take a look. If is on a localhost there is nothing more I can do for you unless it's publicly accessible. I've confirmed both integrations working perfectly fine and suspect something installed or server configuration causing it to fail. None of them will work if your host has disabled "create_function" which allows creation of anonymous functions.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 1 day ago #180212 by pepperstreet
Replied by pepperstreet on topic Re: GroupJive 2.4 | Class 'cbgjAuto' not found
sorry, local MAMP 1.9.6 at the moment.
Where can i check the create_function... ?
Maybe i will try the newer MAMP 2.0.2 package (stay tuned)

Also installed on my own homepage webspace, GJ2.4 -> Auto does work here.
So, i guess it is a problem with MAMP increadentials?!? But I never had such problems before.

Please Log in to join the conversation.

9 years 1 day ago #180231 by krileon

So, i guess it is a problem with MAMP increadentials?!? But I never had such problems before.

Would sound like the problem is with your localhost. Don't know what to advise as I do not use MAMP. I recommend XAMPP, which is what I use (they offer Linux, Windows, etc.. versions). Perhaps upgrading to latest MAMP may also solve your problem.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 1 day ago #180252 by pepperstreet
Replied by pepperstreet on topic Re: GroupJive 2.4 | Class 'cbgjAuto' not found
Online test with Joomla 1.5, CB 1.7.0, GJ 2.4, AutoActions and Auto integration.

1.) GJ Auto integration works fine. (created an auto group with username OnAfterLogin)
2.) Tried the same with CBAutoActions. The new auto does not save the parameters! There is a success message. But when I edit the action... the GJ Category select box is reset! My previous Category is not specified anymore.

3.) The Trigger select box shows BeforeUserFirstLogin TWO times. I am also missing OnAfterFirstLogin. Shouldn´t it available?

(Sent a PM with login)

Please Log in to join the conversation.

9 years 1 day ago #180257 by krileon

2.) Tried the same with CBAutoActions. The new auto does not save the parameters! There is a success message. But when I edit the action... the GJ Category select box is reset! My previous Category is not specified anymore.

Confirmed display bug fixed for next release. Whatever you select then save will be used, but when it refreshes it won't display right. It's purely cosmetic so make your configuration, save it, and it'll work off what you configured.

3.) The Trigger select box shows BeforeUserFirstLogin TWO times. I am also missing OnAfterFirstLogin. Shouldn´t it available?

Duplicate entry, there is no after first login trigger; removed for next release.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.417 seconds

Facebook Twitter LinkedIn