[SOLVED] spambot replaces email with ...

1 week 6 days ago - 1 week 2 days ago #316180 by softforge
Hi we have cb and cbsubs. I have been through the settings of both and cannot for the life of me find any setting to turn off the spambot. Its replacing the view of emails to guest users with ...

You can see it here
www.publishingtrainingcentre.co.uk/cb-profile/8432-alisonboyce-icloud-com
I have switched off the joomla email cloaking but that had no effect. I just want the emails to show.

Any ideas where or what is making this happen in cb? If I go to other pages on the site not under cb control its fine

Kind regards


Phil

If you like our plugins, please consider writing a review on the Joomla Extension Directory or the Community Builder Directory ...
1 week 6 days ago #316182 by krileon
The email cloaking is always applied. There is no option to disable it. Looks like the JS that reveals the email address doesn't exist on the page for some reason. Are you using caching or 3rd party JS caching/compression extension? If caching of any kind is enable try purging the cache.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 week 5 days ago #316211 by softforge
I thought the same so excluded those pages from speed cache and still, the issue is there before posting this in forum.

On the dev site I have disabled all caching from third party. still have the problem. It is fine if I am logged in to the back but as soon as fully logged out the ... appears. This has been fine for years but seems to have surfaced around the time of the last update of cb.and joomla

If I switch all joomla caching off, then its fine. Switch just conservative caching on (file) then not good.

I would rather caching than the cb email cloaking as I could use regular labs one which has a lot of options and does seem to work fine on other sites.

Is my only option to remove it from the core cb files?

This is with just on joomla system settings of progressive or conservative with the page cache plugin off its still ...

www.dev.publishingtrainingcentre.co.uk/cb-profile/9416-avengernaut

If you like our plugins, please consider writing a review on the Joomla Extension Directory or the Community Builder Directory ...
1 week 5 days ago #316215 by krileon
Don't know what to tell you. Something is wrong with Joomla cache then unless you've a 3rd party cache extension doing page caching. The jQuery is just flat out not being output. This would suggest the output buffer is being altered or an old copy of the output buffer is being displayed, which should only be the case if page caching is enabled.

Ensure CBs system plugin in Extensions > Plugins is public, published, and ordered to load first as it will try to clear page cache for CB pages for you. I guess worst case you could edit the email field and under Parameters > Layouts set the Profile Value Layout to to override the output with raw database value.[email] to override the output with raw database value.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 week 2 days ago #316276 by softforge
Your last suggestion worked well and the Regularlabs spam protector works with it so I have caching back on and all is good, thanks

If you like our plugins, please consider writing a review on the Joomla Extension Directory or the Community Builder Directory ...
Moderators: beatnantkrileon
Time to create page: 0.411 seconds

Facebook Twitter LinkedIn