[SOLVED] users aren't getting email confirmation

1 month 3 weeks ago - 1 month 2 weeks ago #326165 by qneal78710
Fresh install of Joomla 4.

set Allow User Registration => (Yes, independent of CMS, "Allow Registration")
set Email Confirmation => (Yes)

and I set the joomla registration plugin "User_Joomla!" => Notification Mail to User => (No) just like I saw you in the video

My email server works because I am able to send email out to different yahoo accounts, and the account I'm testing on has a yahoo email account, so emails are getting there, but when I try to register to my website using the yahoo user account, the account never receives any confirmation email with a link inside. I have check the spam folder consistently and there is nothing there. I even deleted all spam email and ran a test and still nothing.I keep deleting the user on the backend and keep testing but nothing changes.

Please Log in to join the conversation.

1 month 3 weeks ago #326166 by qneal78710
Replied by qneal78710 on topic users aren't getting email confirmation
Turning on joomla "system debug" and setting it to debug "everything" shows absolutely nothing in any of the files. I clear all debug files and tested and nothing gets logged when I try to register to the website.

Please Log in to join the conversation.

1 month 2 weeks ago #326178 by krileon
Replied by krileon on topic users aren't getting email confirmation
Within CB > User Management click the checkbox next to the user you want to email. Next click Mass Mail and try sending them an email. This will let us know if emails are working in general or if it's just the confirmation email not being sent.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 2 weeks ago #326187 by qneal78710
Replied by qneal78710 on topic users aren't getting email confirmation
Please close ticket. I found that I needed to have an extra MX record in my DNS records mail.domainname.com. This had nothing to do with your community builder. Now all users on yahoo and google mail are getting confirmation emails with registration links.

Sorry!
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.176 seconds

Facebook Twitter LinkedIn