[SOLVED] Users Only Subscribed if Access Set to Author

11 years 1 week ago - 11 years 1 week ago #151178 by MH1
Hi,

I have CBSubs 1.1.2 and CB 1.3.1

I have two identical plans, set to free and never expires. Both plans are set to use CB defaults for email confirmation and moderation, which is Confirm Registration and Moderation set to No.

Plan A has User Group set to "Registered" under the access tab

Plan B has User Group set to "Author" under the access tab

Registering for Plan B works fine and the users are properly registered with the correct group (Author), all workflows run, such as CB Login first and subsequent login URLs and the user is shown as subscribed in User Management. The plan shows correctly on the Subscriptions Tab on their profile,

However, with Plan A, the user is registered fine (Registered permission level), but is not shown as subscribed to any plan in User Management and no CB Login workflows run. It shows them as subscribed to Plan A on their Subscriptions Tab in their profile, but there is no Unsubscribe link. They also do not show up under subscriptions for Plan A.

Now, if I change the User Group of Plan A from "Registered" to "Author" under the access tab, everything works fine.

I have double-checked everything and with the exception of Plan A having one field hidden in "Hides fields at registration", all other settings between the two plans is identical.

Any ideas what could be causing this?

Please Log in to join the conversation.

11 years 1 week ago #151185 by krileon

However, with Plan A, the user is registered fine (Registered permission level), but is not shown as subscribed to any plan in User Management and no CB Login workflows run. It shows them as subscribed to Plan A on their Subscriptions Tab in their profile, but there is no Unsubscribe link. They also do not show up under subscriptions for Plan A.

Is Plan A a free lifetime plan? If so have you configured within CBSubs > Settings > Global to create subscriptions for lifetime plans? Please also check at the bottom of the Workflows tab you're not allowing multiple subscriptions for Plan A. If none of the above resolves your issues please PM backend login credentials.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 1 week ago #151189 by MH1
Thanks very much, I enabled CBSubs > Settings > Global create subscriptions for lifetime plans and all is now working fine.

Many thanks for the quick resolution.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.141 seconds

Facebook Twitter LinkedIn