[SOLVED] Fatal Error after Upgrad CB 1.2 - 1.31

11 years 4 months ago - 11 years 3 months ago #151598 by Andrea1966
Hallo,

I'm using Joomla 1.5.21 and after upgrade CB 1.2.3 to 1.3.1 I got the following massage:

Fatal error: Cannot redeclare _pear_call_destructors() (previously declared in libraries/pear/PEAR.php:773) in /administrator/components/com_comprofiler/library/pear/pear.php on line 811

Now the backend shows CB version 1.3.1 but also a massage, that the installation is not complete.

Has anybody an idea what the problem is?

Thanks.
Andrea

Please Log in to join the conversation.

11 years 4 months ago #151634 by krileon
Replied by krileon on topic Re: Fatal Error after Upgrad CB 1.2 - 1.31
Please disable Joomla system plugins 1 by 1 until resolved. This is usually do to a 3rd party extension that is loading the PEAR library at all times causing CB and Joomlas to conflict.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 4 months ago #151668 by Andrea1966
Replied by Andrea1966 on topic Re: Fatal Error after Upgrad CB 1.2 - 1.31
Dear Krileon,

Thanks for your fast answer. I have disabled the Joomla system plugins (system - Cache, system -debug and so on)but without success. I have still the same problem. The second step of installation is not done and when I try to do it, I got still the same error massage. :S

Please Log in to join the conversation.

11 years 4 months ago #151702 by krileon
Replied by krileon on topic Re: Fatal Error after Upgrad CB 1.2 - 1.31
Please PM backend login credentials and will take a look for you. It's either a CB or Joomla plugin causing this or if some sort of modification was made to load Joomlas PEAR library at all times.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 years 3 months ago #152719 by krileon
Replied by krileon on topic Re: Fatal Error after Upgrad CB 1.2 - 1.31
Have successfully upgraded your installation to CB 1.3.1. Please inspect to ensure everything is working as expected. Please keep in mind if you had any core edits in place they are not preserved with upgrades.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: Andrea1966

Please Log in to join the conversation.

11 years 3 months ago #152755 by Andrea1966
Replied by Andrea1966 on topic Re: Fatal Error after Upgrad CB 1.2 - 1.31
Thanks a lot! It seems that everything works fine. I have to upgrade CB Subs now - hopefully without problems.

Andrea :)

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.192 seconds

Facebook Twitter LinkedIn