[#4911] CB Connect Google and Facebook login problems

6 years 9 months ago #262780 by waynesj
Attachments left off last response
Attachments:

Please Log in to join the conversation.

6 years 9 months ago - 6 years 9 months ago #262836 by krileon

I still get this error
Authentication failed! Facebook returned an invalid user id.

Your host likely doesn't have OpenSSL. You need cURL, OpenSSL, and fopen for CB Connect to fully function. Without OpenSSL you won't be able to make HTTPS cURL requests and Facebook will reject the request.

When I try Linked in, I get the following error:
Forbidden

I'm guessing you configured your application wrong and the redirect isn't going to the correct location. Please see the below screenshots.




For Google
I get: "Sign up with Google is not permitted."

Twitter
I get: Sign up with Twitter is not permitted.

You turned off registration for those two. Navigate to CB Connect > Paramaters > Google and Twitter then enable registration again.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Attachments:

Please Log in to join the conversation.

6 years 9 months ago #262877 by waynesj
Hi and thanks for the feedback.

Re Facebook, I will investigate the issues you mention.

For LinkedIn, the application is setup correctly. I checked against your screen shot. My screen attached for reference. Still get this error:
You don't have permission to access /components/com_comprofiler/plugin/user/plug_cbconnect/endpoint.php on this server.



For Google and Twitter (as with all options) I have purposely turned of registration as I only want people who are members on my site, ie they have an account on my server to be able to login using their social credentials. I don't want them to be able to create an account using social credentials.
Attachments:

Please Log in to join the conversation.

6 years 9 months ago #262953 by krileon

For LinkedIn, the application is setup correctly. I checked against your screen shot. My screen attached for reference. Still get this error:
You don't have permission to access /components/com_comprofiler/plugin/user/plug_cbconnect/endpoint.php on this server.

Sounds like you've htaccess configured and it's not allowing direct access. Check Joomla root all the way to endpoint.php for an htaccess file that maybe doing that.

For Google and Twitter (as with all options) I have purposely turned of registration as I only want people who are members on my site, ie they have an account on my server to be able to login using their social credentials. I don't want them to be able to create an account using social credentials.

Then you need to login with Joomla and Link a social site to your existing account. Just clicking it without being logged in will give you that error as registrations through it are not allowed.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 years 8 months ago #263376 by waynesj
Hi
I am trying to download the CB Connect &.0 beta, but cannot seem to find it anywhere.
Each time I go to the download page, I get a page asking me to upgrade to professional membership, which I recently did. This week.

Also, in my profile I see no download history.

Please advise

Wayne

Please Log in to join the conversation.

6 years 8 months ago #263392 by nant

waynesj wrote: Hi
I am trying to download the CB Connect &.0 beta, but cannot seem to find it anywhere.
Each time I go to the download page, I get a page asking me to upgrade to professional membership, which I recently did. This week.

Also, in my profile I see no download history.

Please advise

Wayne


www.joomlapolis.com/component/docman/doc_details/757-cb-connect-700-beta-1

quicklinks for everything here:
www.joomlapolis.com/cb-20-addon-status

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.267 seconds

Facebook Twitter LinkedIn