WYSIWYG doesn't display

14 years 2 months ago #2204 by jeffhoneyager
I have been furiously adding a few Editor Text Area fields - something occured (I wish I could replicate it). Now when I log in via the front end and try to edit my profile, and the Editor Text Area field I added doesn't display with the WYSIWYG editor.

I change editors in Site Configuation - no luck.
I deleted the field and re-created it - no luck.

The same behavior occurs in the Components|CB|User Management and selecting a user to edit. The Editor Text Area field doesn't display.

I've tried both editor TMEdit and TinyMCE Editor.

If I select No WYSIWYG Editor in the Golbal Configuation I can edit the Field from the CB User Manager. When I add text, the text is displayed from the FE, but doesn't allow editing (or display) from the FE.

What did I do?
How do I correct it?

Help!

Thanks
Jeff

Post edited by: jeffhoneyager, at: 2005/12/15 22:18
14 years 2 months ago #2380 by alexwalker
Likeweise I have created fields using the editorta field, and I am unable to get it to focus so I can add some text. I can see all the icons in the WYSIWG but that's all. Nor does it work if I login at the front end. Help !
14 years 2 months ago #2382 by jeffhoneyager
I found this at: forum.joomla.org/index.php/topic,9832.0.html

Chay referenced: www.netshinesoftware.com/mambo-troubleshooter.html

It looks like some people have found this to be helpful. I pasted the "solution below."

I've tried all the suggestions and keep getting weird results.

I installed TinyMCE4Mambo and it started working again. The editor loaded, content loaded on both FE & BE. I was happy and relieved (I've got 4 sites to go live within 2 weeks). Then the next day - same problem. No editor is displayed, no content is displayed - zip.

Now in IE when I select "Update Profile" while logged in as a registered user, I get a pop-up error:

"Internet Explorer cannot open the Internet site.
...gives the url for the com_comprofiler.

Operation aborted"

What does this mean? Is it related?



Chay referenced: www.netshinesoftware.com/mambo-troubleshooter.html

1) Problem: HTML Editor (eg. TinyMCE) Unresponsive
Description: Sometimes, you find that you cannot enter text into the HTML editor, or click on the HTML editor's toolbar buttons - you are locked out of editing your content!

Possible Cause(s): This is usually a problem with javascript permissions. Javascript can only work in a single 'domain', so if resources are required from more than 1 domain to do a job, javascript applications such as HTML editors can crash. The most common reason why HTML editors in mambo try to access resources from more than one domain is that the user tries to access the page without using "www." before the domain name (or, it could be that you are trying to access the page with the "www." but shouldn't be). For example, usually mydomain.com/administrator is wrong. It should be www.mydomain.com/administrator .

Resolution: Whether or not to use "www." depends on the settings in your configuration.php file. Go to Site->Global Configuration (from the main menu in Mambo), click on the Server tab, and check the 'Live Site' setting. If the live site setting includes www. then you must use www. when accessing mambo administrator. If live site does not include www. then you must not use www. when accessing mambo administrator.

If this does not solve your problem, a good place to start troubleshooting is to check for javascript errors. In IE6, a little yellow icon appears in the bottom left of your browser when a javascript error occurs - double-click on it to see the error message. In Firefox, click on Tools->JavaScript Console for a list of the errors.

Post edited by: jeffhoneyager, at: 2005/12/18 18:05
Moderators: beatnantkrileon
Time to create page: 0.419 seconds

Facebook Twitter LinkedIn