Redirect problems after login and login state

2 months 23 hours ago #318527 by activha
Hello

Seems like we have a problem with the latest updates of CB and CB subs regarding the routing of some pages.

For instance on Chrome, if we are logged in and try to access CB activity we are redirected to the connection page showing logged in but not to the correct link.

This behavior occurs since upgrade of both CB/CBsubs to latest builds and K2 v2.10.3 but I cannot trace the problem

In order to try use the demo at activ-ha.com/fr with user : demotest1 and password : demoactiv and try to click on the second and fourth button on the bottom nav bar on chrome.

Instead of loading the "adherent/mes-commissions" and "flow" page we keep getting directed to the connection page showing logged.

Can you help me on this ?

Jean

Please Log in to join the conversation.

2 months 23 hours ago #318529 by krileon
Replied by krileon on topic Redirect problems after login and login state
Do you have a public and published Joomla menu item to CBs profile page? This is mandatory as it's used as the fallback Itemid for URLs.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 22 hours ago - 2 months 22 hours ago #318534 by activha
Replied by activha on topic Redirect problems after login and login state
Yes we have the menu as public.
Everything was working fine until this morning and I don't know how to debug this behavior. Something is routing some menu links set for registered group back to connection page and I cannot figure why.

Do you think that k2 changes to headers could conflict with CB ?

Please Log in to join the conversation.

2 months 5 hours ago #318546 by activha
Replied by activha on topic Redirect problems after login and login state
I think that the problem comes from K2 version 2.10.3 which is screwing a lot of things on joomla cache, etag management, new headers and url routing.
Have reverted to 2.10.2 and reported to them.
Maybe it can help someone else, DO NOT INSTALL v 2.10.3
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.498 seconds

Facebook Twitter LinkedIn