[#8456] CBSubs registration pages suddenly blank

2 months 2 weeks ago - 2 months 1 week ago #324257 by boyjahq
We have not added any new extensions or plugins other than updating to the newest nightly build of Community Builder today. But for some reason our links to registration pages are now showing as blank.

URLs we are using (and have been using for a very long time):

Plan 1
index.php?option=com_comprofiler&view=pluginclass&plugin=cbpaidsubscriptions&do=displayplans&plans=1&lang=jp

Plan 2
index.php?option=com_comprofiler&view=pluginclass&plugin=cbpaidsubscriptions&do=displayplans&plans=2&lang=en
index.php?option=com_comprofiler&view=pluginclass&plugin=cbpaidsubscriptions&do=displayplans&plans=2&lang=jp

I have gone over every possible setting to see if, by chance, something important was somehow modified, but I can find nothing.

Is there something I should look at the might give a clue as to why this suddenly started happening?

Please Log in to join the conversation.

2 months 2 weeks ago #324263 by krileon
Replied by krileon on topic CBSubs registration pages suddenly blank
Nothing changed in regards to the behavior of those URLs so they should be working fine as expected. By blank do you mean the entire page is blank or just where the component content should be (e.g. you can still see your modules around the page). If it's completely blank it suggests some kind of fatal server error is happening and being suppressed. If just the component content area is blank it likely means the plan isn't accessible or the plugin isn't.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 2 weeks ago - 2 months 2 weeks ago #324275 by boyjahq
Replied by boyjahq on topic CBSubs registration pages suddenly blank
The website is showing, it is just the CBSubs part that has disappeared. All settings for plans and CBSubs global configuration are the same as they have been for a long time.

CB Paid Subscriptions plugin version 4.5.0+build.2021.03.01.06.37.41.6701638db is installed and published

Registration settings
Show subscription plans at registration = Yes
Allow Free Registered Users (without subscriptions) = No
Create Subscriptions also for free lifetime plans = Yes

Renewals and upgrade settings
Show Renew/Reactivate buttons = Yes
Show subscription plans upgrade possibilities = Yes

Both of our plans are published with
Allow new subscriptions = Yes
Allow registration = Yes
Allow upgrade to this = Yes
Access Level = Public
Access group = Public

CBSubs itself seems to be working, as logged in users can see their subscriptions tab and can renew or upgrade, etc. And the plugin is generating expiration emails and processing mailer items normally.

I have created a few new Auto Actions recently, so just to check, I disabled all Auto Actions, but it had no effect.

Do you have any suggestions of other places/settings I should check?

Attachments:

Please Log in to join the conversation.

2 months 1 week ago #324279 by krileon
Replied by krileon on topic CBSubs registration pages suddenly blank
Please PM super user login credentials and will take a look. It's also displaying the header for the page as well to suggest that the plugin is reachable.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 1 week ago #324296 by boyjahq
Replied by boyjahq on topic CBSubs registration pages suddenly blank
Sent login info

Please Log in to join the conversation.

2 months 1 week ago - 2 months 1 week ago #324297 by krileon
Replied by krileon on topic CBSubs registration pages suddenly blank
Ok, looks like this was a bug in CBSubs with an old IF check. I've fixed the IF check which is pending review and merge for release. I've went ahead and patched your install to fix it for you now though and confirmed works fine now.

forge.joomlapolis.com/issues/8456


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: boyjahq

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.517 seconds

Facebook Twitter LinkedIn