[#7624] Stripe Prorating

1 month 2 weeks ago - 1 month 1 week ago #313083 by wjgadmin
Hi all,
We've generated a coupon code for a recurring subscription that discounted the first month only (prorated amount). It is worth noting this was an upgrade from one subscription to another (our settings only allow 1 user subscription so it always cancels any other active subscription). The payment appeared to go through however in our admin it showed as not paid. When checking with Stripe, they said it was "incomplete" and needed to be re-run. They further mentioned that we may want to ensure payment methods are applied when proration is applied.
Can you please confirm this should work as expected? Or is there a change that is needed from CBSubs? We will be completely cancelling the users subscription and trying to run it again. Thank you
1 month 2 weeks ago #313113 by krileon
Ensure CB, CBSubs, and CBSubs Stripe are both up to date. Then check the API version within Stripe and in CBSubs Stripe to ensure you're up to date (latest API version 2019-05-16 is supported). For a recurring subscription if the first payment is discounted the subscription at Stripe is put into a Trial period and the initial payment is done as a charge. Check within CBSubs > Notifications to see if your site received the notification for the payment. If not check within CBSubs > History Log to see if an error logged for the payment.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 2 weeks ago #313130 by wjgadmin
Hi
CBSubs, Joomla & Stripe are all on the latest versions. I’ve checked everything & only see the following in the history logs:

Error Log:
stripe Stripe Payment Intent API HTTPS POST request to payment gateway server failed.

Change Log:
Updating payment basket status: Pending because of event received: subscr_signup. Previous status was: NotInitiated

We processed this twice & both times we received the same result. We have many other payments working as intended so hopefully this is an isolated event. It shows as “trial period” in stripe as you suggested, however it shows as “incomplete” there. There must be something to do with the trial/proration being submitted properly.

I had to manually “Pay Now” for the user and for some reason it set their account to “Not Auto recurring” / “Manual”. I’ve had to edit their subscription to set it back to auto recurring mandatory. Please let me know how we should proceed?
1 month 2 weeks ago #313149 by krileon

Error Log:
stripe Stripe Payment Intent API HTTPS POST request to payment gateway server failed.

Looks like the API request to Stripes payment intents endpoint failed entirely. Did you be sure everything is up to date and update the API version in CBSubs Stripe within your Stripe account to be sure you're using latest implementation?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
1 month 2 weeks ago #313152 by wjgadmin
Yes sir,
Stripe dashboard version: 2019-05-16
CBSubs version: 2019-03-14
CB version: 2.4.2
Joomla version: 3.9.8 (I do see there is 3.9.9 available today but it wasn't at the time, I will wait for a resolution before updating)

I tried this multiple times (twice) and got the same result. I would think it was possible for a server issue or something but since it was multiple times at very different times (more than 24 hours apart), it cannot be coincidental.
Please let me know how to proceed?
1 month 2 weeks ago - 1 month 2 weeks ago #313161 by krileon
Within Stripe > Developers > Logs you should be able to see failed API attempts there. If you don't then the request to Stripe was entirely blocked. If the request was entirely blocked it'd be a problem with your server or site.

You said you manually paid their subscription after seeing this. Did they actually pay you though? When this happens no payment should've exchanged since the initial process failed. If the subscription is trialing with no initial payment then the user never paid the initial payment.

This only happens while using a coupon correct? This works fine when not using a coupon? If this is the case does this happen on every recurring subscription with a coupon? I was not able to confirm any issues with coupons being applied to a recurring subscription in my tests.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Templates - CBSubs - Hosting - Forge - Incubator - GroupJive
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM EST to 4:00 PM EST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Moderators: beatnantkrileon
Time to create page: 0.386 seconds
Facebook Twitter Google LinkedIn